summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@gentoo.org>2022-08-07 11:15:30 +0200
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2022-08-07 11:15:37 +0200
commit17fb2dda49960b9f8201b66db84de1837329f782 (patch)
tree09de770cc387633b4b7a3c5541ba86ca53a2e0c8 /games-util
parentgames-util/lutris: enable python3_11 (diff)
downloadgentoo-17fb2dda49960b9f8201b66db84de1837329f782.tar.gz
gentoo-17fb2dda49960b9f8201b66db84de1837329f782.tar.bz2
gentoo-17fb2dda49960b9f8201b66db84de1837329f782.zip
games-util/lutris: update 9999
Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
Diffstat (limited to 'games-util')
-rw-r--r--games-util/lutris/lutris-9999.ebuild9
1 files changed, 7 insertions, 2 deletions
diff --git a/games-util/lutris/lutris-9999.ebuild b/games-util/lutris/lutris-9999.ebuild
index d0cf69b3a9e0..8808cea2f845 100644
--- a/games-util/lutris/lutris-9999.ebuild
+++ b/games-util/lutris/lutris-9999.ebuild
@@ -7,7 +7,7 @@ PYTHON_COMPAT=( python3_{8..11} )
PYTHON_REQ_USE="sqlite,threads(+)"
DISTUTILS_SINGLE_IMPL="1"
-inherit distutils-r1 virtualx xdg
+inherit distutils-r1 optfeature virtualx xdg
DESCRIPTION="An open source gaming platform for GNU/Linux"
HOMEPAGE="https://lutris.net/"
@@ -26,7 +26,7 @@ else
fi
fi
-LICENSE="GPL-3"
+LICENSE="GPL-3+ CC0-1.0"
SLOT="0"
RDEPEND="
@@ -35,6 +35,7 @@ RDEPEND="
app-arch/unzip
$(python_gen_cond_dep '
dev-python/dbus-python[${PYTHON_USEDEP}]
+ dev-python/lxml[${PYTHON_USEDEP}]
dev-python/pillow[${PYTHON_USEDEP}]
dev-python/pygobject:3[${PYTHON_USEDEP}]
dev-python/python-evdev[${PYTHON_USEDEP}]
@@ -50,6 +51,7 @@ RDEPEND="
x11-apps/xgamma
x11-apps/xrandr
x11-libs/gtk+:3[introspection]
+ x11-libs/gdk-pixbuf[jpeg]
x11-libs/libnotify[introspection]
"
@@ -69,7 +71,10 @@ python_install_all() {
pkg_postinst() {
xdg_pkg_postinst
+ optfeature "running windows games through wine+DXVK/proton or other Vulkan games (plus ICD for your hardware)" media-libs/vulkan-loader
+
# Quote README.rst
+ elog ""
elog "Lutris installations are fully automated through scripts, which can"
elog "be written in either JSON or YAML. The scripting syntax is described"
elog "in ${EROOT}/usr/share/doc/${PF}/installers.rst.bz2, and is also"