summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2024-09-25 04:20:59 -0400
committerIonen Wolkens <ionen@gentoo.org>2024-09-25 04:30:45 -0400
commit1fa2b715d6f02e35bdb7104d8e40a7f96ff622df (patch)
treeb02c48e9ef4edbed9d5f665dd1d6f3f1d3b9822e /games-strategy
parentgames-strategy/freeciv: drop 3.1.0 (diff)
downloadgentoo-1fa2b715d6f02e35bdb7104d8e40a7f96ff622df.tar.gz
gentoo-1fa2b715d6f02e35bdb7104d8e40a7f96ff622df.tar.bz2
gentoo-1fa2b715d6f02e35bdb7104d8e40a7f96ff622df.zip
games-strategy/freeciv: remove USE=qt5 and default to qt6
Haven't looked at this ebuild/package too closely, just quickly done to avoid conflicts when qt5 and qt6 are set globally at same time. Should be no need for a revbump given keeping USE=qt6 to select between the multiple toolkits. Given both qt5 and qt6 call the binary "freeciv-qt", the change should be seamless for users. Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'games-strategy')
-rw-r--r--games-strategy/freeciv/freeciv-3.1.2.ebuild20
-rw-r--r--games-strategy/freeciv/freeciv-9999.ebuild20
2 files changed, 8 insertions, 32 deletions
diff --git a/games-strategy/freeciv/freeciv-3.1.2.ebuild b/games-strategy/freeciv/freeciv-3.1.2.ebuild
index eca61092a9e5..3409c6c89308 100644
--- a/games-strategy/freeciv/freeciv-3.1.2.ebuild
+++ b/games-strategy/freeciv/freeciv-3.1.2.ebuild
@@ -25,15 +25,12 @@ fi
LICENSE="GPL-2+"
SLOT="0"
-IUSE="dedicated gtk3 gtk4 json mapimg modpack mysql nls +qt5 qt6 readline rule-editor sdl +server +sound +system-lua web-server"
+IUSE="dedicated gtk3 gtk4 json mapimg modpack mysql nls +qt6 readline rule-editor sdl +server +sound +system-lua web-server"
-# I'm pretty sure that you can't build both qt flavours at the same time
REQUIRED_USE="
system-lua? ( ${LUA_REQUIRED_USE} )
- !dedicated? ( || ( gtk3 gtk4 qt5 qt6 sdl ) )
- dedicated? ( !gtk3 !gtk4 !mapimg !nls !qt5 !qt6 !sdl !sound )
- qt5? ( !qt6 )
- qt6? ( !qt5 )
+ !dedicated? ( || ( gtk3 gtk4 qt6 sdl ) )
+ dedicated? ( !gtk3 !gtk4 !mapimg !nls !qt6 !sdl !sound )
"
RDEPEND="
@@ -51,14 +48,7 @@ RDEPEND="
gtk4? ( gui-libs/gtk:4 )
mapimg? ( media-gfx/imagemagick:= )
nls? ( virtual/libintl )
- qt5? (
- dev-qt/qtcore:5
- dev-qt/qtgui:5
- dev-qt/qtwidgets:5
- )
- qt6? (
- dev-qt/qtbase:6[gui,widgets]
- )
+ qt6? ( dev-qt/qtbase:6[gui,widgets] )
sdl? (
media-libs/libsdl2[video]
media-libs/sdl2-gfx
@@ -132,9 +122,7 @@ src_configure() {
freeciv_enable_ui sdl sdl2 cli
freeciv_enable_ui gtk3 gtk3.22 gtk3
freeciv_enable_ui gtk4
- freeciv_enable_ui qt5 qt
freeciv_enable_ui qt6 qt
- use qt5 && emesonargs+=( -Dqtver=qt5 )
use qt6 && emesonargs+=( -Dqtver=qt6 )
else
if use modpack ; then
diff --git a/games-strategy/freeciv/freeciv-9999.ebuild b/games-strategy/freeciv/freeciv-9999.ebuild
index eca61092a9e5..3409c6c89308 100644
--- a/games-strategy/freeciv/freeciv-9999.ebuild
+++ b/games-strategy/freeciv/freeciv-9999.ebuild
@@ -25,15 +25,12 @@ fi
LICENSE="GPL-2+"
SLOT="0"
-IUSE="dedicated gtk3 gtk4 json mapimg modpack mysql nls +qt5 qt6 readline rule-editor sdl +server +sound +system-lua web-server"
+IUSE="dedicated gtk3 gtk4 json mapimg modpack mysql nls +qt6 readline rule-editor sdl +server +sound +system-lua web-server"
-# I'm pretty sure that you can't build both qt flavours at the same time
REQUIRED_USE="
system-lua? ( ${LUA_REQUIRED_USE} )
- !dedicated? ( || ( gtk3 gtk4 qt5 qt6 sdl ) )
- dedicated? ( !gtk3 !gtk4 !mapimg !nls !qt5 !qt6 !sdl !sound )
- qt5? ( !qt6 )
- qt6? ( !qt5 )
+ !dedicated? ( || ( gtk3 gtk4 qt6 sdl ) )
+ dedicated? ( !gtk3 !gtk4 !mapimg !nls !qt6 !sdl !sound )
"
RDEPEND="
@@ -51,14 +48,7 @@ RDEPEND="
gtk4? ( gui-libs/gtk:4 )
mapimg? ( media-gfx/imagemagick:= )
nls? ( virtual/libintl )
- qt5? (
- dev-qt/qtcore:5
- dev-qt/qtgui:5
- dev-qt/qtwidgets:5
- )
- qt6? (
- dev-qt/qtbase:6[gui,widgets]
- )
+ qt6? ( dev-qt/qtbase:6[gui,widgets] )
sdl? (
media-libs/libsdl2[video]
media-libs/sdl2-gfx
@@ -132,9 +122,7 @@ src_configure() {
freeciv_enable_ui sdl sdl2 cli
freeciv_enable_ui gtk3 gtk3.22 gtk3
freeciv_enable_ui gtk4
- freeciv_enable_ui qt5 qt
freeciv_enable_ui qt6 qt
- use qt5 && emesonargs+=( -Dqtver=qt5 )
use qt6 && emesonargs+=( -Dqtver=qt6 )
else
if use modpack ; then