summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-07-01 09:44:53 +0000
committerSam James <sam@gentoo.org>2022-07-01 09:45:03 +0000
commit3879aa52afd9e9b5f9cacd67a5eb3a06b9806dee (patch)
tree956a96c944ef81aab37521315fe685593a271d2e /games-simulation
parentmedia-sound/csound: bump to 6.17.0, eapi8, added python 3.10 & 3.11, updated ... (diff)
downloadgentoo-3879aa52afd9e9b5f9cacd67a5eb3a06b9806dee.tar.gz
gentoo-3879aa52afd9e9b5f9cacd67a5eb3a06b9806dee.tar.bz2
gentoo-3879aa52afd9e9b5f9cacd67a5eb3a06b9806dee.zip
games-simulation/corsix-th: fix Lua detection
I swear I remember checking the compile lines, too! I dunno what happened there. Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'games-simulation')
-rw-r--r--games-simulation/corsix-th/corsix-th-0.66-r1.ebuild (renamed from games-simulation/corsix-th/corsix-th-0.66.ebuild)1
-rw-r--r--games-simulation/corsix-th/files/corsix-th-0.66-cmake_lua_detection.patch14
2 files changed, 8 insertions, 7 deletions
diff --git a/games-simulation/corsix-th/corsix-th-0.66.ebuild b/games-simulation/corsix-th/corsix-th-0.66-r1.ebuild
index 07f24a781502..37a6785596eb 100644
--- a/games-simulation/corsix-th/corsix-th-0.66.ebuild
+++ b/games-simulation/corsix-th/corsix-th-0.66-r1.ebuild
@@ -56,6 +56,7 @@ PATCHES=(
src_configure() {
local mycmakeargs=(
+ -DLUA_VERSION=$(lua_get_version)
-DWITH_AUDIO=$(usex sound)
-DWITH_FREETYPE2=$(usex truetype)
-DWITH_MOVIES=$(usex videos)
diff --git a/games-simulation/corsix-th/files/corsix-th-0.66-cmake_lua_detection.patch b/games-simulation/corsix-th/files/corsix-th-0.66-cmake_lua_detection.patch
index b201aa4877f8..f85d1bfb0b89 100644
--- a/games-simulation/corsix-th/files/corsix-th-0.66-cmake_lua_detection.patch
+++ b/games-simulation/corsix-th/files/corsix-th-0.66-cmake_lua_detection.patch
@@ -1,13 +1,13 @@
diff --git a/CorsixTH/CMakeLists.txt b/CorsixTH/CMakeLists.txt
-index 1544810..d9d3332 100644
+index 1544810..05ed3b0 100644
--- a/CorsixTH/CMakeLists.txt
+++ b/CorsixTH/CMakeLists.txt
-@@ -129,7 +129,7 @@ endif()
-
- # Find Lua
- if(MSVC AND USE_VCPKG_DEPS)
-- find_package(Lua CONFIG REQUIRED)
-+ find_package(Lua ${LUA_VERSION} EXACT REQUIRED)
+@@ -133,7 +133,7 @@ if(MSVC AND USE_VCPKG_DEPS)
target_link_libraries(CorsixTH_lib lua)
target_link_libraries(CorsixTH lua)
else()
+- find_package(Lua REQUIRED)
++ find_package(Lua ${LUA_VERSION} EXACT REQUIRED)
+ if(Lua_FOUND OR LUA_FOUND)
+ target_link_libraries(CorsixTH ${LUA_LIBRARY})
+ include_directories(${LUA_INCLUDE_DIR})