summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /games-roguelike/crossfire-client
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'games-roguelike/crossfire-client')
-rw-r--r--games-roguelike/crossfire-client/Manifest2
-rw-r--r--games-roguelike/crossfire-client/crossfire-client-1.70.0.ebuild80
-rw-r--r--games-roguelike/crossfire-client/crossfire-client-1.71.0.ebuild79
-rw-r--r--games-roguelike/crossfire-client/files/crossfire-client-1.70.0-gold.patch16
-rw-r--r--games-roguelike/crossfire-client/metadata.xml8
5 files changed, 185 insertions, 0 deletions
diff --git a/games-roguelike/crossfire-client/Manifest b/games-roguelike/crossfire-client/Manifest
new file mode 100644
index 000000000000..67878eae8843
--- /dev/null
+++ b/games-roguelike/crossfire-client/Manifest
@@ -0,0 +1,2 @@
+DIST crossfire-client-1.70.0.tar.gz 801043 SHA256 afa3981785689baa22813ebc3893250c2f73374dda64bfc1dc41e64f4adc60b2 SHA512 ce5b07cd6de03bd2dd28bbb85798ff26ad6764ee5490ba3920b160f6aa109bf5ae409d98855081b4498c3e8fee2e04f2f64a03553366d5f283bca516880e3bd7 WHIRLPOOL b407206deefc5aad6dadabfd37895938587209d3af395cd2a630062fa4102056dd66c01d3e2924d4ae633851b85807735b1d6225eba35194c1c4654181df206e
+DIST crossfire-client-1.71.0.tar.bz2 761156 SHA256 5427655e756ffb48e75c1d9dc3200afab81efa7f2f00ffdf5dfee51918d5819d SHA512 86710d684fd7908ea9aaf5ba20bff0f1ba01ff0ba90c3e2847afff9d0db6f60c7b671413c8888b513c992fbf27474e744b79df185d5e2c04afc9d2dce3d8665e WHIRLPOOL 7a51aac98d4df3f057e201f900faa2fc5f46c180cc57e11db063307fce4510823cc8ef4da62c72bff9dc9a66756de71b93b2dd2e7e759b02c376c7d973d10f9e
diff --git a/games-roguelike/crossfire-client/crossfire-client-1.70.0.ebuild b/games-roguelike/crossfire-client/crossfire-client-1.70.0.ebuild
new file mode 100644
index 000000000000..0dd1ed406f44
--- /dev/null
+++ b/games-roguelike/crossfire-client/crossfire-client-1.70.0.ebuild
@@ -0,0 +1,80 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit toolchain-funcs gnome2-utils games
+
+DESCRIPTION="Client for the nethack-style but more in the line of UO"
+HOMEPAGE="http://crossfire.real-time.com/"
+SRC_URI="mirror://sourceforge/crossfire/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+IUSE="alsa lua oss sdl"
+
+RDEPEND="alsa? ( media-libs/alsa-lib )
+ virtual/opengl
+ x11-libs/gtk+:2
+ gnome-base/libglade
+ sdl? ( media-libs/libsdl[video]
+ media-libs/sdl-image )
+ lua? ( dev-lang/lua )
+ net-misc/curl
+ media-libs/freeglut
+ media-libs/libpng:0
+ sys-libs/zlib"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_prepare() {
+ sed -ri -e '/^.TH/s:$: 6:' $(find . -name "*man") || die
+}
+
+src_configure() {
+ # bugs in configure script so we cant use $(use_enable ...)
+ local myconf
+
+ use sdl || myconf="${myconf} --disable-sdl"
+ use alsa || myconf="${myconf} --disable-alsa9 --disable-alsa"
+ if ! use alsa && ! use oss ; then
+ myconf="${myconf} --disable-sound"
+ fi
+ egamesconf ${myconf}
+}
+
+src_compile() {
+ # bug 139785
+ if use alsa || use oss ; then
+ emake -j1 -C sound-src AR="$(tc-getAR)"
+ fi
+ emake AR="$(tc-getAR)"
+}
+
+src_install() {
+ local s
+
+ emake DESTDIR="${D}" install
+ dodoc AUTHORS ChangeLog README TODO
+ domenu gtk-v2/crossfire-client.desktop
+ for s in 16 32 48
+ do
+ newicon -s ${s} pixmaps/${s}x${s}.png ${PN}.png
+ done
+ prepgamesdirs
+}
+
+pkg_preinst() {
+ games_pkg_preinst
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}
diff --git a/games-roguelike/crossfire-client/crossfire-client-1.71.0.ebuild b/games-roguelike/crossfire-client/crossfire-client-1.71.0.ebuild
new file mode 100644
index 000000000000..fe4e0267199c
--- /dev/null
+++ b/games-roguelike/crossfire-client/crossfire-client-1.71.0.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit toolchain-funcs gnome2-utils games
+
+DESCRIPTION="Client for the nethack-style but more in the line of UO"
+HOMEPAGE="http://crossfire.real-time.com/"
+SRC_URI="mirror://sourceforge/crossfire/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~ppc x86"
+IUSE="alsa lua opengl oss sdl"
+
+RDEPEND="alsa? ( media-libs/alsa-lib )
+ opengl? ( virtual/opengl
+ media-libs/freeglut )
+ x11-libs/gtk+:2
+ gnome-base/libglade
+ sdl? ( media-libs/libsdl[video]
+ media-libs/sdl-image[png] )
+ lua? ( dev-lang/lua )
+ net-misc/curl
+ media-libs/libpng:0
+ sys-libs/zlib"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_prepare() {
+ sed -ri -e '/^.TH/s:$: 6:' $(find . -name "*man") || die
+}
+
+src_configure() {
+ # bugs in configure script so we cant use $(use_enable ...)
+ local myconf
+
+ use sdl || myconf="${myconf} --disable-sdl"
+ use alsa || myconf="${myconf} --disable-alsa9 --disable-alsa"
+ if ! use alsa && ! use oss ; then
+ myconf="${myconf} --disable-sound"
+ fi
+ egamesconf ${myconf}
+}
+
+src_compile() {
+ # bug 139785
+ if use alsa || use oss ; then
+ emake -C sound-src AR="$(tc-getAR)"
+ fi
+ emake AR="$(tc-getAR)"
+}
+
+src_install() {
+ local s
+
+ default
+ domenu gtk-v2/crossfire-client.desktop
+ for s in 16 32 48
+ do
+ newicon -s ${s} pixmaps/${s}x${s}.png ${PN}.png
+ done
+ prepgamesdirs
+}
+
+pkg_preinst() {
+ games_pkg_preinst
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}
diff --git a/games-roguelike/crossfire-client/files/crossfire-client-1.70.0-gold.patch b/games-roguelike/crossfire-client/files/crossfire-client-1.70.0-gold.patch
new file mode 100644
index 000000000000..74dbe1334b70
--- /dev/null
+++ b/games-roguelike/crossfire-client/files/crossfire-client-1.70.0-gold.patch
@@ -0,0 +1,16 @@
+From: Julian Ospald <hasufell@gentoo.org>
+Date: Mon Jan 28 08:14:23 UTC 2013
+Subject: fix underlinking
+
+--- crossfire-client-1.70.0/configure.ac
++++ crossfire-client-1.70.0/configure.ac
+@@ -242,6 +242,9 @@
+ AC_PROG_CPP
+ AC_PROG_RANLIB
+
++# Check for X11
++PKG_CHECK_MODULES([X], [x11])
++
+ AC_SUBST(X_LIBS)
+ AC_SUBST(X_CFLAGS)
+
diff --git a/games-roguelike/crossfire-client/metadata.xml b/games-roguelike/crossfire-client/metadata.xml
new file mode 100644
index 000000000000..19f7d9af42ad
--- /dev/null
+++ b/games-roguelike/crossfire-client/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>games</herd>
+ <upstream>
+ <remote-id type="sourceforge">crossfire</remote-id>
+ </upstream>
+</pkgmetadata>