summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /games-puzzle/wizznic
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'games-puzzle/wizznic')
-rw-r--r--games-puzzle/wizznic/Manifest1
-rw-r--r--games-puzzle/wizznic/metadata.xml8
-rw-r--r--games-puzzle/wizznic/wizznic-306.ebuild52
3 files changed, 61 insertions, 0 deletions
diff --git a/games-puzzle/wizznic/Manifest b/games-puzzle/wizznic/Manifest
new file mode 100644
index 000000000000..8ebc31b41e93
--- /dev/null
+++ b/games-puzzle/wizznic/Manifest
@@ -0,0 +1 @@
+DIST Wizznic_src_build_306.tar.bz2 37019286 SHA256 864b51e20f97b918950d20631c8498e44ea55b8a79a64041ae60b73fa9a5926d SHA512 499b43bf8d1fe4b187e0a3c1f186fbd629ae7a7b3fa993d581b4db2a7f5025d44381f001fe5f3ca769d882040c4ae07d30f53025f119502cfa6f5a97e109ae54 WHIRLPOOL 6fd49bb67dd76a3ac7f8528a98961f1723fd097e9d8bb327edba34d921a711841f5a40c1788ddfc8e3db1ece1c1e0054054002deb462abb80c1e226055dac7f4
diff --git a/games-puzzle/wizznic/metadata.xml b/games-puzzle/wizznic/metadata.xml
new file mode 100644
index 000000000000..de9fd8181495
--- /dev/null
+++ b/games-puzzle/wizznic/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>games</herd>
+ <upstream>
+ <remote-id type="sourceforge">wizznic</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/games-puzzle/wizznic/wizznic-306.ebuild b/games-puzzle/wizznic/wizznic-306.ebuild
new file mode 100644
index 000000000000..c77919033fcf
--- /dev/null
+++ b/games-puzzle/wizznic/wizznic-306.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils games
+
+DESCRIPTION="Block-clearing puzzle game"
+HOMEPAGE="http://wizznic.sourceforge.net/"
+SRC_URI="mirror://sourceforge/wizznic/Wizznic_src_build_${PV}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+DEPEND="media-libs/libsdl[sound,joystick,video]
+ media-libs/sdl-image[png]
+ media-libs/sdl-mixer[vorbis]"
+
+S=${WORKDIR}/Wizznic_src_build_${PV}
+
+src_prepare() {
+ sed \
+ -e '/^\(CC\|LD\|STRIP\)/d' \
+ -e 's/(LD)/(CC)/g' \
+ -e '/man1/s/1/6/g' \
+ Makefile.linux > Makefile || die
+ mv doc/wizznic.1 doc/wizznic.6 || die
+ sed -i \
+ -e '/Dt WIZZNIC/s/1/6/' \
+ doc/wizznic.6 || die
+}
+
+src_compile() {
+ emake \
+ DATADIR="${GAMES_DATADIR}/${PN}/" \
+ BINDIR="${GAMES_BINDIR}" \
+ STRIP=true
+}
+
+src_install() {
+ emake \
+ DESTDIR="${D}" \
+ DATADIR="${GAMES_DATADIR}/${PN}/" \
+ BINDIR="${GAMES_BINDIR}" \
+ install
+ dodoc doc/{changelog.txt,credits.txt,media-licenses.txt,ports.txt,readme.txt}
+ newicon data/wmicon.png ${PN}.png
+ make_desktop_entry wizznic "Wizznic!"
+ prepgamesdirs
+}