summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /games-puzzle/angrydd
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'games-puzzle/angrydd')
-rw-r--r--games-puzzle/angrydd/Manifest1
-rw-r--r--games-puzzle/angrydd/angrydd-1.0.1-r1.ebuild51
-rw-r--r--games-puzzle/angrydd/metadata.xml5
3 files changed, 57 insertions, 0 deletions
diff --git a/games-puzzle/angrydd/Manifest b/games-puzzle/angrydd/Manifest
new file mode 100644
index 000000000000..6ff47216a646
--- /dev/null
+++ b/games-puzzle/angrydd/Manifest
@@ -0,0 +1 @@
+DIST angrydd-1.0.1.tar.gz 5331883 SHA256 e4950cf9c059302632f88340aad23f389e335b21e266672b8ac5ae0f9fab30ee SHA512 e0901833febcabb6622bb85405189bfaf3c917c3254ce282045d58e8e5b5c6c6565ca0e7c56fe2819e0d3f344df3bb285cca54c360b467d284739673d1aa74f0 WHIRLPOOL 50014010a387098feb2a077e981313fc89d7742aad9bf17d11f07ddfef0b14cf749c1e1bdb30214a8d71f045513742251d54478dd18544e2ed70b1216d033cf1
diff --git a/games-puzzle/angrydd/angrydd-1.0.1-r1.ebuild b/games-puzzle/angrydd/angrydd-1.0.1-r1.ebuild
new file mode 100644
index 000000000000..57df8d25fe9a
--- /dev/null
+++ b/games-puzzle/angrydd/angrydd-1.0.1-r1.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+inherit eutils python-single-r1 games
+
+DESCRIPTION="Angry, Drunken Dwarves, a falling blocks game similar to Puzzle Fighter"
+HOMEPAGE="http://www.sacredchao.net/~piman/angrydd/"
+SRC_URI="http://www.sacredchao.net/~piman/angrydd/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+IUSE=""
+
+DEPEND="dev-python/pygame[${PYTHON_USEDEP}]
+ ${PYTHON_DEPS}"
+RDEPEND=${DEPEND}
+REQUIRED_USE=${PYTHON_REQUIRED_USE}
+
+pkg_setup() {
+ python-single-r1_pkg_setup
+ games_pkg_setup
+}
+
+src_prepare() {
+ python_fix_shebang .
+}
+
+src_install() {
+ emake \
+ DESTDIR="${D}" \
+ PREFIX="${GAMES_DATADIR}" \
+ TO="${PN}" \
+ install
+ rm -rf "${D}${GAMES_DATADIR}/games" "${D}${GAMES_DATADIR}/share" || die
+
+ python_optimize "${D}${GAMES_DATADIR}/${PN}"
+
+ dodir "${GAMES_BINDIR}"
+ dosym "${GAMES_DATADIR}/${PN}/angrydd.py" "${GAMES_BINDIR}/${PN}"
+ doman angrydd.6
+ dodoc README TODO HACKING
+
+ doicon angrydd.png
+ make_desktop_entry angrydd "Angry, Drunken Dwarves"
+
+ prepgamesdirs
+}
diff --git a/games-puzzle/angrydd/metadata.xml b/games-puzzle/angrydd/metadata.xml
new file mode 100644
index 000000000000..d3c2cc926f0b
--- /dev/null
+++ b/games-puzzle/angrydd/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>games</herd>
+</pkgmetadata>