summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /games-misc/sdljoytest
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'games-misc/sdljoytest')
-rw-r--r--games-misc/sdljoytest/Manifest1
-rw-r--r--games-misc/sdljoytest/metadata.xml8
-rw-r--r--games-misc/sdljoytest/sdljoytest-11102003.ebuild42
3 files changed, 51 insertions, 0 deletions
diff --git a/games-misc/sdljoytest/Manifest b/games-misc/sdljoytest/Manifest
new file mode 100644
index 000000000000..6745793e88e1
--- /dev/null
+++ b/games-misc/sdljoytest/Manifest
@@ -0,0 +1 @@
+DIST SDLJoytest-GL-11102003.tar.bz2 85997 SHA256 306aa4b825ad880e71aac77d410f7a040ee6c1a372eb3d1db3301a8536a3c468 SHA512 4994e878eaacacb156d4d9988d1e7864ed4e5e3d4db6bc0be8a883d7edde87d56698eb22de5d39e2110be7f960e5bf080283a7563bb2bc3f17c390181e097c6a WHIRLPOOL d029b72346c92c4502fb28d5070cb695110f84e1d5be4a12c303f6b342c948ac7adffe9c9168037efd652b92c607e2fbf438cdbc7ceb2241b926edc261d7acd3
diff --git a/games-misc/sdljoytest/metadata.xml b/games-misc/sdljoytest/metadata.xml
new file mode 100644
index 000000000000..7a55811def1a
--- /dev/null
+++ b/games-misc/sdljoytest/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>games</herd>
+ <upstream>
+ <remote-id type="sourceforge">sdljoytest</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/games-misc/sdljoytest/sdljoytest-11102003.ebuild b/games-misc/sdljoytest/sdljoytest-11102003.ebuild
new file mode 100644
index 000000000000..56c9598d6600
--- /dev/null
+++ b/games-misc/sdljoytest/sdljoytest-11102003.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit toolchain-funcs
+
+DESCRIPTION="SDL app to test joysticks and game controllers"
+HOMEPAGE="http://sdljoytest.sourceforge.net/"
+SRC_URI="mirror://sourceforge/sdljoytest/SDLJoytest-GL-${PV}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+IUSE=""
+
+DEPEND="media-libs/libsdl[joystick,opengl,video]
+ virtual/opengl
+ media-libs/sdl-image"
+RDEPEND=${DEPEND}
+
+S=${WORKDIR}/SDLJoytest-GL
+
+src_prepare() {
+ emake clean
+ sed -i -e 's:/usr/local:/usr:' joytest.h || die
+ sed -i -e 's:SDL/::' *.c || die
+}
+
+src_compile() {
+ emake \
+ CC=$(tc-getCC) \
+ CFLAGS="$(sdl-config --cflags) ${CFLAGS}" \
+ LDFLAGS="$(sdl-config --libs) -lGL ${LDFLAGS}"
+}
+
+src_install() {
+ dobin SDLJoytest-GL
+ insinto /usr/share/SDLJoytest-GL
+ doins *.bmp
+ doman SDLJoytest.1
+}