summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-04-06 02:35:13 +0100
committerSam James <sam@gentoo.org>2021-04-06 19:18:00 +0100
commit27a8c4e324fdc026db44835220377ec515543d60 (patch)
tree95bde4d983f0ca35cd5cd2a136a26228dd705051 /games-fps/quake1-rally
parentgames-puzzle/nightsky: port to EAPI 7, games.eclass-- (diff)
downloadgentoo-27a8c4e324fdc026db44835220377ec515543d60.tar.gz
gentoo-27a8c4e324fdc026db44835220377ec515543d60.tar.bz2
gentoo-27a8c4e324fdc026db44835220377ec515543d60.zip
games-fps/quake1-rally: port to EAPI 7, games.eclass--
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'games-fps/quake1-rally')
-rw-r--r--games-fps/quake1-rally/quake1-rally-1.2-r1.ebuild (renamed from games-fps/quake1-rally/quake1-rally-1.2.ebuild)33
1 files changed, 17 insertions, 16 deletions
diff --git a/games-fps/quake1-rally/quake1-rally-1.2.ebuild b/games-fps/quake1-rally/quake1-rally-1.2-r1.ebuild
index e7c086e83cbe..5b4137c84763 100644
--- a/games-fps/quake1-rally/quake1-rally-1.2.ebuild
+++ b/games-fps/quake1-rally/quake1-rally-1.2-r1.ebuild
@@ -1,38 +1,39 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
-inherit eutils games
+EAPI=7
+
+inherit edos2unix
DESCRIPTION="TC which turns Quake into a Rally racing game"
HOMEPAGE="http://wiki.quakeworld.nu/Quake_Rally"
SRC_URI="http://ehall.freeshell.org/quake/qr12.zip
http://ehall.freeshell.org/quake/qrlo1.zip"
+S="${WORKDIR}"
LICENSE="all-rights-reserved"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE=""
-RESTRICT="mirror bindist"
-RDEPEND=""
-DEPEND="app-arch/unzip"
+RESTRICT="mirror bindist"
-S=${WORKDIR}
+BDEPEND="app-arch/unzip"
src_unpack() {
- echo ">>> Unpacking qr12.zip to ${PWD}"
+ einfo "Unpacking qr12.zip to ${PWD}"
unzip -qoLL "${DISTDIR}"/qr12.zip || die "unpacking qr12.zip failed"
- echo ">>> Unpacking qrlo1.zip to ${PWD}"
+
+ einfo "Unpacking qrlo1.zip to ${PWD}"
unzip -qoLL "${DISTDIR}"/qrlo1.zip || die "unpacking qrlo1.zip failed"
- rm -f button.wav qrally.exe
- cd rally
- edos2unix $(find . -name '*.txt' -o -name '*.cfg')
- mv rally{,.example}.cfg
+
+ rm -f button.wav qrally.exe || die
+ cd rally || die
+
+ edos2unix $(find . -name '*.txt' -o -name '*.cfg' || die)
+ mv rally{,.example}.cfg || die
}
src_install() {
- insinto "${GAMES_DATADIR}/quake1"
+ insinto /usr/share/quake1
doins -r *
- prepgamesdirs
}