summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /games-fps/doom3-roe
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'games-fps/doom3-roe')
-rw-r--r--games-fps/doom3-roe/doom3-roe-1.ebuild54
-rw-r--r--games-fps/doom3-roe/metadata.xml13
2 files changed, 67 insertions, 0 deletions
diff --git a/games-fps/doom3-roe/doom3-roe-1.ebuild b/games-fps/doom3-roe/doom3-roe-1.ebuild
new file mode 100644
index 000000000000..887863ac6cf4
--- /dev/null
+++ b/games-fps/doom3-roe/doom3-roe-1.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit eutils cdrom games
+
+DESCRIPTION="Doom III: Resurrection of Evil expansion pack"
+HOMEPAGE="http://www.doom3.com/"
+SRC_URI=""
+
+LICENSE="DOOM3"
+SLOT="0"
+KEYWORDS="-* amd64 x86"
+IUSE=""
+RESTRICT="strip"
+
+RDEPEND=">=games-fps/doom3-1.3.1302-r2"
+
+S=${WORKDIR}
+
+dir=${GAMES_PREFIX_OPT}/doom3
+Ddir=${D}/${dir}
+
+src_unpack() {
+ cdrom_get_cds Setup/Data/d3xp/pak000.pk4
+ # Change from showing "d3xp" in the "mods" menu within Doom 3
+ # The ^1 changes the text to red
+ echo '^1Resurrection of Evil' > description.txt
+}
+
+src_install() {
+ insinto "${dir}"/d3xp
+
+ einfo "Copying file from the disk..."
+ doins "${CDROM_ROOT}"/Setup/Data/d3xp/pak000.pk4 \
+ || die "copying pak000"
+
+ doins description.txt
+
+ find "${Ddir}" -exec touch '{}' \;
+
+ games_make_wrapper ${PN} "doom3 +set fs_game d3xp"
+ make_desktop_entry ${PN} "Doom III - Resurrection of Evil" doom3
+
+ prepgamesdirs
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+
+ elog "This is just the data portion of the game. You will need to emerge"
+ elog "games-fps/doom3 to play the game."
+ echo
+}
diff --git a/games-fps/doom3-roe/metadata.xml b/games-fps/doom3-roe/metadata.xml
new file mode 100644
index 000000000000..d2321302edc6
--- /dev/null
+++ b/games-fps/doom3-roe/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>games</herd>
+<longdescription>
+Science has unlocked the gates to the unknown, and now only one man stands
+between Hell and Earth. A sci-fi horror masterpiece, DOOM 3 is like nothing you
+have experienced. Dramatic storyline, pulse-pounding action, incredible
+graphics, and revolutionary technology combine to draw you into the most
+frightening and gripping first person gaming experience ever created. For more
+information, checkout http://www.doom3.com
+</longdescription>
+</pkgmetadata>