summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnna (navi) Figueiredo Gomes <navi@vlhl.dev>2023-04-22 14:00:25 -0300
committerSam James <sam@gentoo.org>2023-04-23 08:47:12 +0100
commit429f3311a0dc776e0e4da58463487b0e5038a9c1 (patch)
tree91f7d0c1d895dac78c71436895e28bd87488c9aa /games-arcade
parentnet-misc/sstp-client: fix ppp-2.5.0 patches (diff)
downloadgentoo-429f3311a0dc776e0e4da58463487b0e5038a9c1.tar.gz
gentoo-429f3311a0dc776e0e4da58463487b0e5038a9c1.tar.bz2
gentoo-429f3311a0dc776e0e4da58463487b0e5038a9c1.zip
games-arcade/xgalaga: Add patch to fix Wimplicit-int
Closes: https://bugs.gentoo.org/877287 Signed-off-by: Anna (navi) Figueiredo Gomes <navi@vlhl.dev> Closes: https://github.com/gentoo/gentoo/pull/30705 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'games-arcade')
-rw-r--r--games-arcade/xgalaga/files/xgalaga-2.1.1.0-function-and-ints.patch24
-rw-r--r--games-arcade/xgalaga/xgalaga-2.1.1.0-r2.ebuild (renamed from games-arcade/xgalaga/xgalaga-2.1.1.0-r1.ebuild)3
2 files changed, 26 insertions, 1 deletions
diff --git a/games-arcade/xgalaga/files/xgalaga-2.1.1.0-function-and-ints.patch b/games-arcade/xgalaga/files/xgalaga-2.1.1.0-function-and-ints.patch
new file mode 100644
index 000000000000..349f01216f35
--- /dev/null
+++ b/games-arcade/xgalaga/files/xgalaga-2.1.1.0-function-and-ints.patch
@@ -0,0 +1,24 @@
+Bug: https://bugs.gentoo.org/877287
+--- a/title.c
++++ b/title.c
+@@ -5,6 +5,7 @@
+
+ #include <stdio.h>
+ #include <stdlib.h>
++#include <unistd.h>
+ #ifdef HAVE_FCNTL_H
+ # include <fcntl.h>
+ #endif
+@@ -17,9 +18,9 @@
+ #include "proto.h"
+
+ /* for scrolling credits */
+-const LINESIZE= 70;
+-const VISIBLELINES=7;
+-const SPEEDFACTOR=5;
++const int LINESIZE=70;
++const int VISIBLELINES=7;
++const int SPEEDFACTOR=5;
+ char *gchLBuf;
+ int giCreditLines=0, giActCreditLine=0;
+
diff --git a/games-arcade/xgalaga/xgalaga-2.1.1.0-r1.ebuild b/games-arcade/xgalaga/xgalaga-2.1.1.0-r2.ebuild
index 1b87b13d58d9..a8367332b7e3 100644
--- a/games-arcade/xgalaga/xgalaga-2.1.1.0-r1.ebuild
+++ b/games-arcade/xgalaga/xgalaga-2.1.1.0-r2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -25,6 +25,7 @@ RDEPEND+=" acct-group/gamestat"
PATCHES=(
"${FILESDIR}"/${PN}-2.1.1.0-respect-AR.patch
+ "${FILESDIR}"/${PN}-2.1.1.0-function-and-ints.patch
)
src_prepare() {