summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /games-action/openclonk
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'games-action/openclonk')
-rw-r--r--games-action/openclonk/Manifest2
-rw-r--r--games-action/openclonk/files/openclonk-5.5.1-jpeg9.patch20
-rw-r--r--games-action/openclonk/files/openclonk-5.5.1-paths.patch67
-rw-r--r--games-action/openclonk/files/openclonk-5.5.1-tinyxml-shared.patch25
-rw-r--r--games-action/openclonk/files/openclonk-wrapper-script.sh9
-rw-r--r--games-action/openclonk/metadata.xml21
-rw-r--r--games-action/openclonk/openclonk-5.5.1.ebuild121
7 files changed, 265 insertions, 0 deletions
diff --git a/games-action/openclonk/Manifest b/games-action/openclonk/Manifest
new file mode 100644
index 000000000000..21eb4c31f9f6
--- /dev/null
+++ b/games-action/openclonk/Manifest
@@ -0,0 +1,2 @@
+DIST openclonk-5.5.1-src.tar.bz2 65383438 SHA256 c038d6dc2ef9a3d7966b18ba6147b9dd136f353dfaa5796455f9917b79255743 SHA512 eb111a1f19e2373e6999850dddafa9a5653694904f470690ef39300e4cc3105f0394637e7dbea0a4cff9d91dd30b04f9037252eb0e8830966696f01f6424b977 WHIRLPOOL 990e90ff0daf9aa9dc4826ff621f0647089a68b5ba7d798a4d6cd5ef5d9ec78a666ae897241a6d556f90110f6739206fb09ebc2bc6c9558df65ee67dba0ea8af
+DIST openclonk.png 8487 SHA256 93ff9f479e166f30f1c1042c32624b7e54b4d917813a4f46cce57e39a1f30233 SHA512 3bd2bb20167349130d767719f6732d9682ec32a09f5e8c13fe6245648185eee28edfe564ae64bdc5539c19de701f321887c7fa71e8d1f1f640e0ec6b933544de WHIRLPOOL 190876380614e82092a0d825612cec9dbd0294aec1caf9fe00a137d75525736d87e56507851f61292b736601c1124aac1d1724e94cd0846fa60f5fcab714ef13
diff --git a/games-action/openclonk/files/openclonk-5.5.1-jpeg9.patch b/games-action/openclonk/files/openclonk-5.5.1-jpeg9.patch
new file mode 100644
index 000000000000..161258604e6b
--- /dev/null
+++ b/games-action/openclonk/files/openclonk-5.5.1-jpeg9.patch
@@ -0,0 +1,20 @@
+--- src/graphics/C4SurfaceLoaders.cpp.old 2015-01-02 18:01:35.768676874 +0100
++++ src/graphics/C4SurfaceLoaders.cpp 2015-01-02 18:02:17.705896683 +0100
+@@ -303,7 +303,7 @@
+ // The doc says to give fake end-of-inputs if there is no more data
+ cinfo->src->next_input_byte = &end_of_input;
+ cinfo->src->bytes_in_buffer = 1;
+- return true;
++ return (boolean)true;
+ }
+ static void skip_input_data (j_decompress_ptr cinfo, long num_bytes)
+ {
+@@ -354,7 +354,7 @@
+ blub.term_source = jpeg_noop;
+
+ // a missing image is an error
+- jpeg_read_header(&cinfo, true);
++ jpeg_read_header(&cinfo, (boolean)true);
+
+ // Let libjpeg convert for us
+ cinfo.out_color_space = JCS_RGB;
diff --git a/games-action/openclonk/files/openclonk-5.5.1-paths.patch b/games-action/openclonk/files/openclonk-5.5.1-paths.patch
new file mode 100644
index 000000000000..02776e21ed69
--- /dev/null
+++ b/games-action/openclonk/files/openclonk-5.5.1-paths.patch
@@ -0,0 +1,67 @@
+From: Julian Ospald <hasufell@gentoo.org>
+Date: Thu Feb 6 19:58:45 UTC 2014
+Subject: make paths modifiable
+
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -35,6 +35,16 @@
+ set(${_var} "${_string}" PARENT_SCOPE)
+ endfunction()
+
++
++############################################################################
++# User selectable paths
++############################################################################
++set(INSTALL_BINDIR "bin/" CACHE PATH "Binary install destination")
++set(INSTALL_GAMES_BINDIR "games/bin" CACHE PATH "Games binary install destination")
++set(INSTALL_DATAROOTDIR "share/" CACHE PATH "Data root install destination")
++set(INSTALL_DATADIR "${INSTALL_DATAROOTDIR}" CACHE PATH "Data install destination")
++
++
+ ############################################################################
+ # User selectable options
+ ############################################################################
+@@ -1170,10 +1180,16 @@
+ # Assemble compiler flags
+ ############################################################################
+ if(UNIX)
++ if(NOT IS_ABSOLUTE "${INSTALL_DATADIR}")
++ set(ABSOLUTE_INSTALL_DATADIR "${CMAKE_INSTALL_PREFIX}/${INSTALL_DATADIR}")
++ else()
++ set(ABSOLUTE_INSTALL_DATADIR "${INSTALL_DATADIR}")
++ endif()
++
+ # Don't put this into CMAKE_CXX_FLAGS because otherwise it is cached,
+ # and when the path is changed both the old and new definition appears
+ # in the list of flags.
+- add_definitions("-DOC_SYSTEM_DATA_DIR=\"${CMAKE_INSTALL_PREFIX}/share/games/openclonk\"")
++ add_definitions("-DOC_SYSTEM_DATA_DIR=\"${ABSOLUTE_INSTALL_DATADIR}/openclonk\"")
+ endif()
+ if(OC_CXX_FLAGS)
+ list(REMOVE_DUPLICATES OC_CXX_FLAGS)
+@@ -1474,20 +1490,20 @@
+ DEPENDS c4group
+ VERBATIM
+ )
+- install(FILES ${CMAKE_CURRENT_BINARY_DIR}/${group} DESTINATION share/games/openclonk)
++ install(FILES ${CMAKE_CURRENT_BINARY_DIR}/${group} DESTINATION "${INSTALL_DATADIR}/openclonk")
+ endif()
+ endforeach()
+
+ if (NOT APPLE)
+ add_custom_target(groups DEPENDS ${OC_C4GROUPS})
+ add_dependencies(data groups)
+-
++
+ # Install new files
+- install(FILES ${CMAKE_CURRENT_SOURCE_DIR}/openclonk.desktop DESTINATION share/applications)
++ install(FILES ${CMAKE_CURRENT_SOURCE_DIR}/openclonk.desktop DESTINATION "${INSTALL_DATAROOTDIR}/applications")
+
+ # Install binaries
+- install(TARGETS openclonk DESTINATION games)
+- install(TARGETS c4group DESTINATION bin)
++ install(TARGETS openclonk DESTINATION "${INSTALL_GAMES_BINDIR}")
++ install(TARGETS c4group DESTINATION "${INSTALL_BINDIR}")
+ else()
+ install(TARGETS openclonk
+ BUNDLE DESTINATION .
diff --git a/games-action/openclonk/files/openclonk-5.5.1-tinyxml-shared.patch b/games-action/openclonk/files/openclonk-5.5.1-tinyxml-shared.patch
new file mode 100644
index 000000000000..a55943fc3135
--- /dev/null
+++ b/games-action/openclonk/files/openclonk-5.5.1-tinyxml-shared.patch
@@ -0,0 +1,25 @@
+From: Julian Ospald <hasufell@gentoo.org>
+Date: Thu Feb 6 19:58:45 UTC 2014
+Subject: use shared tinyxml
+
+--- a/CMakeLists.txt.old.new
++++ b/CMakeLists.txt
+@@ -1292,7 +1292,6 @@
+ CHECK_INCLUDE_FILE_CXX(getopt.h HAVE_GETOPT_H)
+
+ # TinyXML
+-add_subdirectory(thirdparty/tinyxml)
+ target_link_libraries(openclonk tinyxml)
+
+ if(WIN32)
+--- a/src/lib/StdMeshLoaderXml.cpp
++++ b/src/lib/StdMeshLoaderXml.cpp
+@@ -19,7 +19,7 @@
+ #include "C4Include.h"
+ #include "StdMesh.h"
+ #include "StdMeshLoader.h"
+-#include <tinyxml/tinyxml.h>
++#include <tinyxml.h>
+
+ // Helper class to load things from an XML file with error checking
+ class StdMeshLoader::StdMeshXML
diff --git a/games-action/openclonk/files/openclonk-wrapper-script.sh b/games-action/openclonk/files/openclonk-wrapper-script.sh
new file mode 100644
index 000000000000..9f7e64442887
--- /dev/null
+++ b/games-action/openclonk/files/openclonk-wrapper-script.sh
@@ -0,0 +1,9 @@
+#!/bin/sh
+# wrapper prevents the game to look for .ocp files in the current dir
+# which can lead to weird behavior and game freeze
+
+[ -d ~/.clonk/openclonk ] || mkdir -p ~/.clonk/openclonk
+
+cd ~/.clonk/openclonk
+
+exec clonk "$@"
diff --git a/games-action/openclonk/metadata.xml b/games-action/openclonk/metadata.xml
new file mode 100644
index 000000000000..c5180b637a68
--- /dev/null
+++ b/games-action/openclonk/metadata.xml
@@ -0,0 +1,21 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>games</herd>
+ <upstream>
+ <changelog>http://hg.openclonk.org/openclonk/</changelog>
+ <doc lang="en">http://wiki.openclonk.org/w/C4Script_Documentation</doc>
+ <bugs-to>http://bugs.openclonk.org/</bugs-to>
+ </upstream>
+ <longdescription lang="en">
+ OpenClonk is the Open source successor of the Clonk gaming series.
+ OpenClonk is a project dedicated to the further development of the
+ Clonk game series. Our goal is to improve and make the real strengths
+ of Clonk more fun to play: Bustling mining, production lines and
+ economy, fast and fiddly melees. Another focus lies on the further
+ enchancement of the game engine and the extensibility/modability of
+ the game content with C4Script which has always been one of the most
+ important features of Clonk.
+ </longdescription>
+</pkgmetadata>
+
diff --git a/games-action/openclonk/openclonk-5.5.1.ebuild b/games-action/openclonk/openclonk-5.5.1.ebuild
new file mode 100644
index 000000000000..fe6d46e67f0d
--- /dev/null
+++ b/games-action/openclonk/openclonk-5.5.1.ebuild
@@ -0,0 +1,121 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+# FIXME: does not compile with gtk+3
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+inherit cmake-utils eutils gnome2-utils python-any-r1 games
+
+MY_P=${PN}-release-${PV}-src
+
+DESCRIPTION="A free multiplayer action game where you control clonks"
+HOMEPAGE="http://openclonk.org/"
+SRC_URI="http://www.openclonk.org/builds/release/${PV}/openclonk-${PV}-src.tar.bz2
+ http://${PN}.org/homepage/icon.png -> ${PN}.png"
+
+LICENSE="BSD ISC CLONK-trademark LGPL-2.1 POSTGRESQL"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="dedicated doc"
+
+RDEPEND="
+ >=dev-libs/boost-1.40
+ dev-libs/tinyxml
+ net-libs/libupnp
+ media-libs/libpng:0
+ sys-libs/zlib
+ !dedicated? (
+ dev-libs/glib:2
+ media-libs/freealut
+ media-libs/freetype:2
+ media-libs/glew
+ media-libs/libsdl[X,opengl,sound,video]
+ media-libs/libvorbis
+ media-libs/openal
+ media-libs/sdl-mixer[mp3,vorbis,wav]
+ virtual/jpeg
+ virtual/opengl
+ virtual/glu
+ x11-libs/gdk-pixbuf
+ x11-libs/gtk+:2
+ x11-libs/libXrandr
+ x11-libs/libX11
+ )
+ dedicated? ( sys-libs/readline:0 )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ doc? (
+ ${PYTHON_DEPS}
+ dev-libs/libxml2[python]
+ sys-devel/gettext
+ )"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-tinyxml-shared.patch
+ "${FILESDIR}"/${P}-paths.patch
+ "${FILESDIR}"/${P}-jpeg9.patch
+)
+S=${WORKDIR}/${PN}-release-${PV}-src
+
+pkg_setup() {
+ games_pkg_setup
+ use doc && python-any-r1_pkg_setup
+}
+
+src_prepare() {
+ rm -r thirdparty/tinyxml || die
+ cmake-utils_src_prepare
+}
+
+src_configure() {
+ local mycmakeargs=(
+ $(usex dedicated \
+ "-DUSE_CONSOLE=ON -DUSE_X11=OFF -DUSE_GTK=OFF -DUSE_GTK3=OFF" \
+ "-DUSE_CONSOLE=OFF -DUSE_X11=ON -DUSE_GTK=ON -DUSE_GTK3=OFF")
+ -DWITH_AUTOMATIC_UPDATE=OFF
+ -DINSTALL_GAMES_BINDIR="${GAMES_BINDIR}"
+ -DINSTALL_DATADIR="${GAMES_DATADIR}"
+ -DUSE_STATIC_BOOST=OFF
+ )
+
+ cmake-utils_src_configure
+}
+
+src_compile() {
+ cmake-utils_src_compile
+
+ if use doc ; then
+ emake -C docs
+ fi
+}
+
+src_install() {
+ cmake-utils_src_install
+
+ if ! use dedicated; then
+ mv "${ED%/}${GAMES_BINDIR}/openclonk" "${ED%/}${GAMES_BINDIR}/clonk" || die
+ newgamesbin "${FILESDIR}"/${PN}-wrapper-script.sh ${PN}
+ doicon -s 64 "${DISTDIR}"/${PN}.png
+ make_desktop_entry ${PN}
+ fi
+ use doc && dohtml -r docs/online/*
+
+ prepgamesdirs
+}
+
+pkg_preinst() {
+ games_pkg_preinst
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}