summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2022-01-08 14:11:43 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2022-01-08 22:07:39 +0100
commitd2899ac1755843011b576e79568a430336d3837c (patch)
tree1871bc2a7514c5a35384180d793af95c78d47934 /eclass/ecm.eclass
parentecm.eclass: Introduce ecm_punt_kf_module and ecm_punt_qt_module (diff)
downloadgentoo-d2899ac1755843011b576e79568a430336d3837c.tar.gz
gentoo-d2899ac1755843011b576e79568a430336d3837c.tar.bz2
gentoo-d2899ac1755843011b576e79568a430336d3837c.zip
ecm.eclass: Use new ecm_punt_kf_module/ecm_punt_qt_module internally
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'eclass/ecm.eclass')
-rw-r--r--eclass/ecm.eclass8
1 files changed, 4 insertions, 4 deletions
diff --git a/eclass/ecm.eclass b/eclass/ecm.eclass
index e81ecd180cc2..cd8110ab27f1 100644
--- a/eclass/ecm.eclass
+++ b/eclass/ecm.eclass
@@ -428,7 +428,7 @@ ecm_src_prepare() {
cmake_comment_add_subdirectory ${ECM_HANDBOOK_DIR}
if [[ ${ECM_HANDBOOK} = forceoptional ]] ; then
- ecm_punt_bogus_dep KF5 DocTools
+ ecm_punt_kf_module DocTools
sed -i -e "/kdoctools_install/I s/^/#DONT/" CMakeLists.txt || die
fi
fi
@@ -453,18 +453,18 @@ ecm_src_prepare() {
# only build unit tests when required
if ! { in_iuse test && use test; } ; then
if [[ ${ECM_TEST} = forceoptional ]] ; then
- ecm_punt_bogus_dep Qt5 Test
+ ecm_punt_qt_module Test
# if forceoptional, also cover non-kde categories
cmake_comment_add_subdirectory autotests test tests
elif [[ ${ECM_TEST} = forceoptional-recursive ]] ; then
- ecm_punt_bogus_dep Qt5 Test
+ ecm_punt_qt_module Test
local f pf="${T}/${P}"-tests-optional.patch
touch ${pf} || die "Failed to touch patch file"
for f in $(find . -type f -name "CMakeLists.txt" -exec \
grep -li "^\s*add_subdirectory\s*\(\s*.*\(auto|unit\)\?tests\?\s*)\s*\)" {} \;); do
cp ${f} ${f}.old || die "Failed to prepare patch origfile"
pushd ${f%/*} > /dev/null || die
- ecm_punt_bogus_dep Qt5 Test
+ ecm_punt_qt_module Test
sed -i CMakeLists.txt -e \
"/^#/! s/add_subdirectory\s*\(\s*.*\(auto|unit\)\?tests\?\s*)\s*\)/if(BUILD_TESTING)\n&\nendif()/I" \
|| die