summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-util/treecc
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-util/treecc')
-rw-r--r--dev-util/treecc/Manifest1
-rw-r--r--dev-util/treecc/metadata.xml5
-rw-r--r--dev-util/treecc/treecc-0.3.10.ebuild48
3 files changed, 54 insertions, 0 deletions
diff --git a/dev-util/treecc/Manifest b/dev-util/treecc/Manifest
new file mode 100644
index 000000000000..49acc37b3722
--- /dev/null
+++ b/dev-util/treecc/Manifest
@@ -0,0 +1 @@
+DIST treecc-0.3.10.tar.gz 375762 SHA256 5e9d20a6938e0c6fedfed0cabc7e9e984024e4881b748d076e8c75f1aeb6efe7 SHA512 426add1a96913a169a0f03a6e3247a8b48c9073335cf967ef05d4d4188fbe3b8ebc837b38b9a4de94ccdb13685ace47a91b185c75a845cf2670e929802774b73 WHIRLPOOL 5667e873e1c02c25944e07721383c94d7363dcc2132d0c89bb531619d191fb25fdfcce4a8e17e2e4336fac7428925910b5e697298337bf991d87c81c005cad2f
diff --git a/dev-util/treecc/metadata.xml b/dev-util/treecc/metadata.xml
new file mode 100644
index 000000000000..e85974a7fa17
--- /dev/null
+++ b/dev-util/treecc/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>dotnet</herd>
+</pkgmetadata>
diff --git a/dev-util/treecc/treecc-0.3.10.ebuild b/dev-util/treecc/treecc-0.3.10.ebuild
new file mode 100644
index 000000000000..d3a95dfd17e4
--- /dev/null
+++ b/dev-util/treecc/treecc-0.3.10.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+DESCRIPTION="compiler-compiler tool for aspect-oriented programming"
+HOMEPAGE="http://www.gnu.org/software/dotgnu"
+SRC_URI="http://download.savannah.gnu.org/releases/dotgnu-pnet/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 s390 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~sparc-solaris"
+IUSE="doc examples"
+
+DEPEND="doc? ( app-text/texi2html )"
+
+src_compile() {
+ econf || die "econf failed"
+ emake || die "emake failed"
+
+ if use doc ; then
+ if [ ! -f "${S}"/doc/treecc.texi ] ; then
+ die "treecc.texi was not generated"
+ fi
+
+ cd "${S}"/doc
+ texi2html -split_chapter "${S}"/doc/treecc.texi \
+ || die "texi2html failed"
+ cd "${S}"
+ fi
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc AUTHORS ChangeLog NEWS README
+
+ if use examples ; then
+ docinto examples
+ dodoc examples/README
+ dodoc examples/{expr_c.tc,gram_c.y,scan_c.l}
+ fi
+
+ if use doc ; then
+ dodoc doc/*.{txt,html}
+
+ docinto html
+ dohtml doc/treecc/*.html
+ fi
+}