summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-util/sasm
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-util/sasm')
-rw-r--r--dev-util/sasm/Manifest1
-rw-r--r--dev-util/sasm/metadata.xml11
-rw-r--r--dev-util/sasm/sasm-2.2.ebuild34
-rw-r--r--dev-util/sasm/sasm-9999.ebuild34
4 files changed, 80 insertions, 0 deletions
diff --git a/dev-util/sasm/Manifest b/dev-util/sasm/Manifest
new file mode 100644
index 000000000000..454678c387a0
--- /dev/null
+++ b/dev-util/sasm/Manifest
@@ -0,0 +1 @@
+DIST sasm-2.2.tar.gz 9117410 SHA256 4441726f7f081304bdddc4be2d139d96140655ed19df6b9ed33da666989d93eb SHA512 42d4af775d37d47bcf63fb70b9142e387e33cef5589002ff3e3cee926b5fca7e1508d640d1d5a175d48fc9fd041eb1f03304cad5ddc3c22a09ff29198650b513 WHIRLPOOL 683c783e2d9e2482e52c3925aa023ae1dcd62b211d7a24d1acf665fd3f3d238ff6325480e1a11216b265478bb4cbfb475664281e3798cc52198745fa71807713
diff --git a/dev-util/sasm/metadata.xml b/dev-util/sasm/metadata.xml
new file mode 100644
index 000000000000..84daad147631
--- /dev/null
+++ b/dev-util/sasm/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>maksbotan@gentoo.org</email>
+ <name>Maxim Koltsov</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">Dman95/SASM</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-util/sasm/sasm-2.2.ebuild b/dev-util/sasm/sasm-2.2.ebuild
new file mode 100644
index 000000000000..84d291de9ea7
--- /dev/null
+++ b/dev-util/sasm/sasm-2.2.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit qt4-r2
+
+if [[ ${PV} == 9999 ]]; then
+ EGIT_REPO_URI="https://github.com/Dman95/SASM.git"
+ SRC_URI=""
+ inherit git-r3
+else
+ SRC_URI="https://github.com/Dman95/SASM/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}/SASM-${PV}"
+fi
+
+DESCRIPTION="Simple crossplatform IDE for NASM assembly language"
+HOMEPAGE="http://dman95.github.io/SASM/"
+
+LICENSE="GPL-3"
+SLOT="0"
+[[ ${PV} == 9999 ]] || \
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="
+ dev-qt/qtcore:4
+ dev-qt/qtgui:4
+"
+REPEND="${DEPEND}
+ dev-lang/nasm
+ sys-devel/gdb
+"
diff --git a/dev-util/sasm/sasm-9999.ebuild b/dev-util/sasm/sasm-9999.ebuild
new file mode 100644
index 000000000000..84d291de9ea7
--- /dev/null
+++ b/dev-util/sasm/sasm-9999.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit qt4-r2
+
+if [[ ${PV} == 9999 ]]; then
+ EGIT_REPO_URI="https://github.com/Dman95/SASM.git"
+ SRC_URI=""
+ inherit git-r3
+else
+ SRC_URI="https://github.com/Dman95/SASM/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}/SASM-${PV}"
+fi
+
+DESCRIPTION="Simple crossplatform IDE for NASM assembly language"
+HOMEPAGE="http://dman95.github.io/SASM/"
+
+LICENSE="GPL-3"
+SLOT="0"
+[[ ${PV} == 9999 ]] || \
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="
+ dev-qt/qtcore:4
+ dev-qt/qtgui:4
+"
+REPEND="${DEPEND}
+ dev-lang/nasm
+ sys-devel/gdb
+"