summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <williamh@gentoo.org>2023-12-11 12:29:00 -0600
committerWilliam Hubbs <williamh@gentoo.org>2023-12-11 12:34:31 -0600
commitd9ae11b1f9fd6f7c7f0a908360b451794fda633a (patch)
tree60c445a3f6a5e60aa021c412f5eeee4b5b4cb67a /dev-util/runme/runme-2.0.5.ebuild
parentapp-text/pdfsandwich: stabilize 0.1.7 for amd64 (diff)
downloadgentoo-d9ae11b1f9fd6f7c7f0a908360b451794fda633a.tar.gz
gentoo-d9ae11b1f9fd6f7c7f0a908360b451794fda633a.tar.bz2
gentoo-d9ae11b1f9fd6f7c7f0a908360b451794fda633a.zip
dev-util/runme: new package, add 2.0.5
This utility turns your documentation into interactive runbooks. Signed-off-by: William Hubbs <williamh@gentoo.org>
Diffstat (limited to 'dev-util/runme/runme-2.0.5.ebuild')
-rw-r--r--dev-util/runme/runme-2.0.5.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-util/runme/runme-2.0.5.ebuild b/dev-util/runme/runme-2.0.5.ebuild
new file mode 100644
index 000000000000..9af10cc64611
--- /dev/null
+++ b/dev-util/runme/runme-2.0.5.ebuild
@@ -0,0 +1,34 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit go-module
+
+# fix these on every bump
+GIT_SHA=bed11d0ed538857f007c55d2ce70905a94111130
+GIT_SHA_SHORT=bed11d0
+VERSION=v${PV}-${GIT_SHA_SHORT}
+
+DESCRIPTION="Execute your runbooks, docs and READMEs"
+HOMEPAGE="https://runme.dev"
+SRC_URI="https://github.com/stateful/runme/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+SRC_URI+=" https://dev.gentoo.org/~williamh/dist/${P}-deps.tar.xz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+
+unset LDFLAGS
+
+src_compile() {
+ emake \
+ GIT_SHA="${GIT_SHA}" \
+ GIT_SHA_SHORT="${GIT_SHA_SHORT}" \
+ VERSION="${VERSION}"
+}
+
+src_install() {
+ dobin runme
+ einstalldocs
+}