summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-util/duma
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-util/duma')
-rw-r--r--dev-util/duma/Manifest3
-rw-r--r--dev-util/duma/duma-2.5.13.ebuild85
-rw-r--r--dev-util/duma/duma-2.5.15-r1.ebuild94
-rw-r--r--dev-util/duma/metadata.xml13
4 files changed, 195 insertions, 0 deletions
diff --git a/dev-util/duma/Manifest b/dev-util/duma/Manifest
new file mode 100644
index 000000000000..e30d2704795e
--- /dev/null
+++ b/dev-util/duma/Manifest
@@ -0,0 +1,3 @@
+DIST duma-2.5.15-GNUmakefile.patch.bz2 4618 SHA256 71c79fedc436402301abc152ff0bca0db505c8641f57c2232a8d2d6e9f3a59b7 SHA512 6d83294897a60c6d0ebac388c8f791adc6a199b2c9838497bcfff39502262014c8437a331e08e3526568d3ef755a7dfdc2557771bdae89c58cd5f714eae70df2 WHIRLPOOL d295b278a35ce1cba7fd4f657c457dbad5a40b8f132632e5a3b1ff618e666a2de75b8347b053aacfaab77550918bcfedb92e8b3f0c6629069b242473c9e5b54f
+DIST duma_2_5_13.tar.gz 233157 SHA256 338757d68f580b38d0680f21151c55e705abf5c933d959410be90fe5c5248777 SHA512 da0f46a697f95cbb17d0dbb3135df779ac347fd9e63c1578d2d732300d5288958d02b5a271e84292a8279c1ebc3dc153f896cbeca916cf18aba8e54788671288 WHIRLPOOL 7262fecfb8a2176c352d0730f2fa2667d985740b2a75f42e7980d9a13f72d494eb9bd1dd4116cec37d03cc5441eb128d405de46e8a718b0a918179c7ae41368b
+DIST duma_2_5_15.tar.gz 240479 SHA256 baaf794854e3093ad1bddadbfb8ad4b220a7117d70359ee216bd59e353734e17 SHA512 0e2abdb08cfbaf9fd0a6be348c831a83ac4ee86d2297dcd1c4d625ddb4b2c1c73eef05e2b895e291d5b8076b1baea559c89d475f30e409210df4ab69b71b6345 WHIRLPOOL b7775cfefa49e942a8243520741920f506b09251e7c0966c2014863589f74a915de4ba8eee77716512ee3ad4071f748beb8ff4c03c95b7242f80aa397c4c51ad
diff --git a/dev-util/duma/duma-2.5.13.ebuild b/dev-util/duma/duma-2.5.13.ebuild
new file mode 100644
index 000000000000..0c3c41620aaa
--- /dev/null
+++ b/dev-util/duma/duma-2.5.13.ebuild
@@ -0,0 +1,85 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit eutils flag-o-matic multilib toolchain-funcs versionator
+
+MY_P="${PN}_$(replace_all_version_separators '_')"
+
+DESCRIPTION="DUMA (Detect Unintended Memory Access) is a memory debugging library"
+HOMEPAGE="http://duma.sourceforge.net/"
+
+SRC_URI="mirror://sourceforge/duma/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+IUSE="examples"
+
+DEPEND=""
+RDEPEND="${DEPEND}
+ app-shells/bash"
+
+S="${WORKDIR}/${MY_P}"
+
+pkg_setup() {
+ #DUMA_OPTIONS="-DDUMA_LIB_NO_LEAKDETECTION"
+ DUMA_OPTIONS="-DDUMA_USE_FRAMENO"
+ if [ -n "${DUMA_OPTIONS}" ]; then
+ ewarn ""
+ elog "Custom build options are ${DUMA_OPTIONS}."
+ else
+ ewarn ""
+ elog "Custom build options are not set!"
+ fi
+ elog "See the package Makefile for for more options (also installed"
+ elog "with package docs as Makefile.duma)."
+ ewarn ""
+}
+
+src_unpack(){
+ unpack ${A}
+ cd "${S}"
+ sed -i -e "s:(prefix)/lib:(prefix)/$(get_libdir):g" Makefile
+ sed -i -e "s:share/doc/duma:share/doc/${P}:g" Makefile
+}
+
+src_compile(){
+ replace-flags O? O0
+ append-flags -Wall -Wextra -U_FORTIFY_SOURCE
+ tc-export AR CC CXX LD RANLIB
+
+ use amd64 && export DUMA_ALIGNMENT=16
+
+ make CPPFLAGS="${DUMA_OPTIONS}" reconfig || die "make reconfig failed"
+ emake CFLAGS="${CFLAGS}" CC=$(tc-getCC) || die "make failed"
+}
+
+src_test() {
+ ewarn "Control-C now if you want to disable tests..."
+ epause 5
+
+ cd "${S}"
+ use amd64 && export DUMA_ALIGNMENT=16
+ make CFLAGS="${DUMA_OPTIONS} ${CFLAGS}" \
+ CC=$(tc-getCC) test || die "make test failed"
+
+ elog ""
+ ewarn "Check output above to verify all tests have passed. Both"
+ ewarn "static and dynamic confidence tests should say PASSED."
+ elog ""
+}
+
+src_install(){
+ # make install fails nicely here on the first file...
+ make DESTDIR="${D}" install || die "make install failed"
+ dodoc CHANGELOG TODO
+ # All the good comments on duma build options are in the Makefile
+ newdoc Makefile Makefile.duma
+
+ if use examples; then
+ insinto /usr/share/doc/${P}/examples
+ doins example[1-6].cpp
+ doins example_makes/ex6/Makefile
+ fi
+}
diff --git a/dev-util/duma/duma-2.5.15-r1.ebuild b/dev-util/duma/duma-2.5.15-r1.ebuild
new file mode 100644
index 000000000000..e295d5720991
--- /dev/null
+++ b/dev-util/duma/duma-2.5.15-r1.ebuild
@@ -0,0 +1,94 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=2
+inherit eutils flag-o-matic multilib toolchain-funcs versionator
+
+MY_P=${PN}_$(replace_all_version_separators '_')
+
+DESCRIPTION="DUMA (Detect Unintended Memory Access) is a memory debugging library"
+HOMEPAGE="http://duma.sourceforge.net"
+SRC_URI="mirror://sourceforge/duma/${MY_P}.tar.gz
+ mirror://gentoo/${P}-GNUmakefile.patch.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="examples"
+
+RDEPEND="app-shells/bash"
+DEPEND="${RDEPEND}"
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ epatch "${DISTDIR}"/${P}-GNUmakefile.patch.bz2
+}
+
+src_compile() {
+ # strip-flags
+ replace-flags O? O0
+ append-flags -Wall -Wextra -U_FORTIFY_SOURCE
+ tc-export AR CC CXX LD RANLIB
+
+ case "${CHOST}" in
+ *-linux-gnu)
+ OS=linux;;
+ *-solaris*)
+ OS=solaris;;
+ *-darwin*)
+ OS=osx;;
+ *-freebsd*)
+ OS=freebsd;;
+ *-netbsd*)
+ OS=netbsd;;
+ *-cygwin*)
+ OS=cygwin;;
+ **-irix**)
+ OS=irix;;
+ esac
+ export OS="${OS}"
+ elog "Detected OS is: ${OS}"
+
+ if use amd64 && ! [ -n "${DUMA_ALIGNMENT}" ]; then
+ export DUMA_ALIGNMENT=16
+ elog "Exported DUMA_ALIGNMENT=${DUMA_ALIGNMENT} for x86_64,"
+ fi
+
+ make reconfig || die "make config failed"
+ # The above must be run first if distcc is enabled, otherwise
+ # the real build breaks on parallel makes.
+ emake || die "emake failed"
+}
+
+src_test() {
+ emake test || die "emake test failed"
+
+ elog "Please, see the output above to verify all tests have passed."
+ elog "Both static and dynamic confidence tests should say PASSED."
+}
+
+src_install(){
+ emake prefix="${D}/usr" libdir="${D}/usr/$(get_libdir)" \
+ docdir="${D}/usr/share/doc/${PF}" install || die "emake install failed"
+
+ dosed "s|LD_PRELOAD=./libduma|LD_PRELOAD=libduma|" /usr/bin/duma \
+ || die "dosed failed"
+
+ dodoc CHANGELOG TODO GNUmakefile
+
+ if use examples; then
+ insinto /usr/share/doc/${PF}/examples
+ doins example[1-6].cpp example_makes/ex6/Makefile || die "doins failed"
+ fi
+}
+
+pkg_postinst() {
+ elog "See the GNUmakefile which will be also installed at"
+ elog "/usr/share/doc/${PF} for more options. You can now export"
+ elog "varibles to the build system easily, e.g.:"
+ elog "# export CPPFLAGS=\"-DFLAG\" (or by using append-cppflags)"
+ elog "# export DUMA_ALIGNMENT=${DUMA_ALIGNMENT} (Default is 16 for x86_64)"
+ elog "See more information about DUMA_ALIGNMENT from Readme.txt"
+}
diff --git a/dev-util/duma/metadata.xml b/dev-util/duma/metadata.xml
new file mode 100644
index 000000000000..38964f6cb5a5
--- /dev/null
+++ b/dev-util/duma/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>dev-tools</herd>
+ <longdescription>
+DUMA is an open-source library (under GNU General Public License) to
+detect buffer overruns and under-runs in C and C++ programs. This
+library is a fork of Buce Perens Electric Fence library and adds
+some new features to it.</longdescription>
+ <upstream>
+ <remote-id type="sourceforge">duma</remote-id>
+ </upstream>
+</pkgmetadata>