summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2024-08-15 08:08:40 +0200
committerHans de Graaff <graaff@gentoo.org>2024-08-15 08:08:40 +0200
commitf7985cf13799750c9d093d30d4a7500f99637772 (patch)
tree1dba5de39437a14d0d9a7d84e70bd0672b4afd39 /dev-ruby
parentdev-python/pipenv: Stabilize 2024.0.1 amd64, #937932 (diff)
downloadgentoo-f7985cf13799750c9d093d30d4a7500f99637772.tar.gz
gentoo-f7985cf13799750c9d093d30d4a7500f99637772.tar.bz2
gentoo-f7985cf13799750c9d093d30d4a7500f99637772.zip
dev-ruby/http-cookie: add 1.0.7
Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/http-cookie/Manifest1
-rw-r--r--dev-ruby/http-cookie/http-cookie-1.0.7.ebuild29
2 files changed, 30 insertions, 0 deletions
diff --git a/dev-ruby/http-cookie/Manifest b/dev-ruby/http-cookie/Manifest
index fb426d0e7aa9..55ee187e045e 100644
--- a/dev-ruby/http-cookie/Manifest
+++ b/dev-ruby/http-cookie/Manifest
@@ -1,2 +1,3 @@
DIST http-cookie-1.0.5.gem 39424 BLAKE2B 569a0d18c962be378f3974b400ddf2289c72490b2b93619fcd83ed6c00bbf5def76239c52163dc6231060792abf3a19988285a6cd28f158ff7339252da912e61 SHA512 d530d64b5c2fc3757a6de03384fe768317e24a523d4a4215f5bcc6b5bca9e7b94eeaad1e52fbb67548396b7b2ca7c9d8b68ea7b99109e24770fcf34c950469ef
DIST http-cookie-1.0.6.gem 40448 BLAKE2B 428cd8aef9d08ff86486c1dab10f75e2cf0aa614eda598a95e35598f945a41cc35cf7a871b4b6b56f01435790c7995d1cb83c2fff46463282d66f0e1cd8a0883 SHA512 088949816b70c3eea5464b492cb067d1d1cea8608ba8ad791876b5a33cc57c95b036420e3e9872a40e35c84168a37ab6b4615a049ea98b04588000cdf594bc5f
+DIST http-cookie-1.0.7.gem 40448 BLAKE2B 36ce6daabaa5e2385fbe5f3db4b18cef8c304ac23f2200978d56ef726c6ed2f5bab09bd779c885bd23207130101b0143833696753e00c71f3504c2696fe15d17 SHA512 ed83e492d60f5af50d184e590ae3bb85be1cc34019619ac8053e0a8249deea239c66076b70b48b2db4066f18fcc478fee5bca118e7ee697b8bbb5f5985da7124
diff --git a/dev-ruby/http-cookie/http-cookie-1.0.7.ebuild b/dev-ruby/http-cookie/http-cookie-1.0.7.ebuild
new file mode 100644
index 000000000000..047a9505786e
--- /dev/null
+++ b/dev-ruby/http-cookie/http-cookie-1.0.7.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+USE_RUBY="ruby31 ruby32 ruby33"
+
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A ruby library to handle HTTP cookies"
+HOMEPAGE="https://github.com/sparklemotion/http-cookie"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+# See https://github.com/sparklemotion/http-cookie/issues/16 for dropping domain_name
+ruby_add_rdepend ">=dev-ruby/domain_name-0.5:0"
+
+all_ruby_prepare() {
+ sed -i -e "/simplecov/d" -e "/bundler/d" Rakefile || die
+}
+
+each_ruby_test() {
+ ${RUBY} -Ilib test/test_http_cookie.rb || die
+ ${RUBY} -Ilib test/test_http_cookie_jar.rb || die
+}