summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2024-08-11 16:16:04 +0200
committerConrad Kostecki <conikost@gentoo.org>2024-08-11 16:22:10 +0200
commitb2d0d1775bb37619e5867e3f5b90500d639c2ea0 (patch)
tree0d4d5b9c478a64fd5d1f155c9d3fcb0c9a92d271 /dev-ruby
parentgames-simulation/openrct2: add 0.4.13 (diff)
downloadgentoo-b2d0d1775bb37619e5867e3f5b90500d639c2ea0.tar.gz
gentoo-b2d0d1775bb37619e5867e3f5b90500d639c2ea0.tar.bz2
gentoo-b2d0d1775bb37619e5867e3f5b90500d639c2ea0.zip
dev-ruby/rrdtool-bindings: add 1.9.0
Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/rrdtool-bindings/Manifest1
-rw-r--r--dev-ruby/rrdtool-bindings/rrdtool-bindings-1.9.0.ebuild64
2 files changed, 65 insertions, 0 deletions
diff --git a/dev-ruby/rrdtool-bindings/Manifest b/dev-ruby/rrdtool-bindings/Manifest
index e3ece643a7cd..8a82f2164d65 100644
--- a/dev-ruby/rrdtool-bindings/Manifest
+++ b/dev-ruby/rrdtool-bindings/Manifest
@@ -1 +1,2 @@
DIST rrdtool-1.8.0.tar.gz 2955398 BLAKE2B d821d662af432c53760bc0e9636b84d9209933a810fa71091fc4c2b44518c89c7ad509bde7955d952279ee41464c3bfa4f631662dde61b6fff46699bb382653f SHA512 8ae6f94d119e8d0e1ba7f2d0738f1ba008a4880d1022f1c0c5436f662d961fceec5c42e01c241493ece3d6f55c60fd7d1d264f93e678f3cf1251201dcde027c1
+DIST rrdtool-1.9.0.tar.gz 2972593 BLAKE2B a5633b1bcacf53823f95f7899872e67d9941faec235c56546de8b66faf15a958a7c0d6a86d569c078e11a478dc272b1fbe784c3d3d9d45e8c3de696f0d6e378a SHA512 ebeb1fd9e1eed8e01d4d08a4f07aa22c272cc95ac87852f81a892690e6f446b5398bf64689ea99622779cba490722d97b325bda2d2a6d4dfc0719929b2a4c041
diff --git a/dev-ruby/rrdtool-bindings/rrdtool-bindings-1.9.0.ebuild b/dev-ruby/rrdtool-bindings/rrdtool-bindings-1.9.0.ebuild
new file mode 100644
index 000000000000..47736a0ab2d9
--- /dev/null
+++ b/dev-ruby/rrdtool-bindings/rrdtool-bindings-1.9.0.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+MY_P="${P/-bindings}"
+MY_P="${MY_P/_/-}"
+
+USE_RUBY="ruby31 ruby32 ruby33"
+RUBY_FAKEGEM_TASK_DOC=""
+
+inherit ruby-ng
+
+DESCRIPTION="Ruby bindings for rrdtool"
+HOMEPAGE="https://oss.oetiker.ch/rrdtool/"
+SRC_URI="https://github.com/oetiker/${PN/-bindings}-1.x/releases/download/v${PV}/${MY_P}.tar.gz"
+RUBY_S="${MY_P}/bindings/ruby"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="graph test"
+RESTRICT="!test? ( test )"
+REQUIRED_USE="test? ( graph )"
+
+# Block on older versions of rrdtool that install the bindings themselves.
+# requires rrd_xport which requires rrd_graph
+RDEPEND="
+ ~net-analyzer/rrdtool-${PV}[graph=]
+"
+DEPEND="
+ ${RDEPEND}
+ test? ( ~net-analyzer/rrdtool-${PV}[graph] )
+"
+
+all_ruby_prepare() {
+ eapply -p3 "${FILESDIR}"/${PN}-1.4.8-graph-ruby.patch
+}
+
+each_ruby_configure() {
+ rm ../../src/rrd_config.h || die
+ touch ../../src/rrd_config.h || die
+
+ ${RUBY} extconf.rb \
+ --with-cflags="${CFLAGS} $(usex graph -DHAVE_RRD_GRAPH -UHAVE_RRD_GRAPH)" || die
+}
+
+each_ruby_compile() {
+ emake V=1 ABS_TOP_SRCDIR="${PWD}/../.."
+}
+
+each_ruby_test() {
+ if use graph; then
+ ${RUBY} -I. test.rb || die
+ fi
+}
+
+all_ruby_install() {
+ dodoc CHANGES README
+}
+
+each_ruby_install() {
+ DESTDIR=${D} emake install
+}