summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-10-04 22:23:34 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2022-10-04 22:27:45 +0300
commit92d4c5e46d7fe8e6fe48afe2b8fd03b887f4626d (patch)
tree2a733c1e0480fd116dba01a19538a99de620eeab /dev-ros
parentdev-ros/ament_cmake_pytest: use python_has_version inside python_check_deps (diff)
downloadgentoo-92d4c5e46d7fe8e6fe48afe2b8fd03b887f4626d.tar.gz
gentoo-92d4c5e46d7fe8e6fe48afe2b8fd03b887f4626d.tar.bz2
gentoo-92d4c5e46d7fe8e6fe48afe2b8fd03b887f4626d.zip
dev-ros/ament_cmake_python: use python_has_version inside python_check_deps
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-ros')
-rw-r--r--dev-ros/ament_cmake_python/ament_cmake_python-1.1.4.ebuild15
-rw-r--r--dev-ros/ament_cmake_python/ament_cmake_python-1.3.0.ebuild13
-rw-r--r--dev-ros/ament_cmake_python/ament_cmake_python-9999.ebuild13
3 files changed, 19 insertions, 22 deletions
diff --git a/dev-ros/ament_cmake_python/ament_cmake_python-1.1.4.ebuild b/dev-ros/ament_cmake_python/ament_cmake_python-1.1.4.ebuild
index d6ff5f678382..9e97d1bcb641 100644
--- a/dev-ros/ament_cmake_python/ament_cmake_python-1.1.4.ebuild
+++ b/dev-ros/ament_cmake_python/ament_cmake_python-1.1.4.ebuild
@@ -1,4 +1,4 @@
-# Copyright 2019-2021 Gentoo Authors
+# Copyright 2019-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -11,7 +11,6 @@ ROS_PN="ament_cmake"
if [ "${PV#9999}" != "${PV}" ] ; then
inherit git-r3
EGIT_REPO_URI="https://github.com/ament/ament_cmake"
- SRC_URI=""
S=${WORKDIR}/${P}/${PN}
else
SRC_URI="https://github.com/ament/ament_cmake/archive/${PV}.tar.gz -> ${ROS_PN}-${PV}.tar.gz"
@@ -28,20 +27,20 @@ if [ "${PV#9999}" != "${PV}" ] ; then
else
KEYWORDS="~amd64"
fi
-IUSE=""
RDEPEND="
dev-ros/ament_cmake_core
"
DEPEND="${RDEPEND}"
# Deps here are transitive from ament_cmake_core to have matching python support
-BDEPEND="
- $(python_gen_any_dep 'dev-python/ament_package[${PYTHON_USEDEP}] dev-python/catkin_pkg[${PYTHON_USEDEP}]')
- ${PYTHON_DEPS}
+BDEPEND="${PYTHON_DEPS}
+ $(python_gen_any_dep '
+ dev-python/ament_package[${PYTHON_USEDEP}]
+ dev-python/catkin_pkg[${PYTHON_USEDEP}]')
"
PATCHES=( "${FILESDIR}/destdir.patch" )
python_check_deps() {
- has_version "dev-python/ament_package[${PYTHON_USEDEP}]" && \
- has_version "dev-python/catkin_pkg[${PYTHON_USEDEP}]"
+ python_has_version "dev-python/ament_package[${PYTHON_USEDEP}]" \
+ "dev-python/catkin_pkg[${PYTHON_USEDEP}]"
}
diff --git a/dev-ros/ament_cmake_python/ament_cmake_python-1.3.0.ebuild b/dev-ros/ament_cmake_python/ament_cmake_python-1.3.0.ebuild
index d4b1a4488aca..efe87c1c7938 100644
--- a/dev-ros/ament_cmake_python/ament_cmake_python-1.3.0.ebuild
+++ b/dev-ros/ament_cmake_python/ament_cmake_python-1.3.0.ebuild
@@ -11,7 +11,6 @@ ROS_PN="ament_cmake"
if [ "${PV#9999}" != "${PV}" ] ; then
inherit git-r3
EGIT_REPO_URI="https://github.com/ament/ament_cmake"
- SRC_URI=""
S=${WORKDIR}/${P}/${PN}
else
SRC_URI="https://github.com/ament/ament_cmake/archive/${PV}.tar.gz -> ${ROS_PN}-${PV}.tar.gz"
@@ -28,20 +27,20 @@ if [ "${PV#9999}" != "${PV}" ] ; then
else
KEYWORDS="~amd64"
fi
-IUSE=""
RDEPEND="
dev-ros/ament_cmake_core
"
DEPEND="${RDEPEND}"
# Deps here are transitive from ament_cmake_core to have matching python support
-BDEPEND="
- $(python_gen_any_dep 'dev-python/ament_package[${PYTHON_USEDEP}] dev-python/catkin_pkg[${PYTHON_USEDEP}]')
- ${PYTHON_DEPS}
+BDEPEND="${PYTHON_DEPS}
+ $(python_gen_any_dep '
+ dev-python/ament_package[${PYTHON_USEDEP}]
+ dev-python/catkin_pkg[${PYTHON_USEDEP}]')
"
PATCHES=( "${FILESDIR}/destdir2.patch" )
python_check_deps() {
- has_version "dev-python/ament_package[${PYTHON_USEDEP}]" && \
- has_version "dev-python/catkin_pkg[${PYTHON_USEDEP}]"
+ python_has_version "dev-python/ament_package[${PYTHON_USEDEP}]" \
+ "dev-python/catkin_pkg[${PYTHON_USEDEP}]"
}
diff --git a/dev-ros/ament_cmake_python/ament_cmake_python-9999.ebuild b/dev-ros/ament_cmake_python/ament_cmake_python-9999.ebuild
index d4b1a4488aca..efe87c1c7938 100644
--- a/dev-ros/ament_cmake_python/ament_cmake_python-9999.ebuild
+++ b/dev-ros/ament_cmake_python/ament_cmake_python-9999.ebuild
@@ -11,7 +11,6 @@ ROS_PN="ament_cmake"
if [ "${PV#9999}" != "${PV}" ] ; then
inherit git-r3
EGIT_REPO_URI="https://github.com/ament/ament_cmake"
- SRC_URI=""
S=${WORKDIR}/${P}/${PN}
else
SRC_URI="https://github.com/ament/ament_cmake/archive/${PV}.tar.gz -> ${ROS_PN}-${PV}.tar.gz"
@@ -28,20 +27,20 @@ if [ "${PV#9999}" != "${PV}" ] ; then
else
KEYWORDS="~amd64"
fi
-IUSE=""
RDEPEND="
dev-ros/ament_cmake_core
"
DEPEND="${RDEPEND}"
# Deps here are transitive from ament_cmake_core to have matching python support
-BDEPEND="
- $(python_gen_any_dep 'dev-python/ament_package[${PYTHON_USEDEP}] dev-python/catkin_pkg[${PYTHON_USEDEP}]')
- ${PYTHON_DEPS}
+BDEPEND="${PYTHON_DEPS}
+ $(python_gen_any_dep '
+ dev-python/ament_package[${PYTHON_USEDEP}]
+ dev-python/catkin_pkg[${PYTHON_USEDEP}]')
"
PATCHES=( "${FILESDIR}/destdir2.patch" )
python_check_deps() {
- has_version "dev-python/ament_package[${PYTHON_USEDEP}]" && \
- has_version "dev-python/catkin_pkg[${PYTHON_USEDEP}]"
+ python_has_version "dev-python/ament_package[${PYTHON_USEDEP}]" \
+ "dev-python/catkin_pkg[${PYTHON_USEDEP}]"
}