summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-10-04 22:29:36 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2022-10-04 22:29:36 +0300
commit1aeb5312d8ec30411838b96a5caeffe3f07f5a71 (patch)
treeb8dc4e62ed8026afe50ffd5e2b41149dc3f44eea /dev-ros
parentdev-ros/ament_cmake_ros: use python_has_version inside python_check_deps (diff)
downloadgentoo-1aeb5312d8ec30411838b96a5caeffe3f07f5a71.tar.gz
gentoo-1aeb5312d8ec30411838b96a5caeffe3f07f5a71.tar.bz2
gentoo-1aeb5312d8ec30411838b96a5caeffe3f07f5a71.zip
dev-ros/ament_cmake_uncrustify: use python_has_version inside python_check_deps
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-ros')
-rw-r--r--dev-ros/ament_cmake_uncrustify/ament_cmake_uncrustify-0.11.2.ebuild8
-rw-r--r--dev-ros/ament_cmake_uncrustify/ament_cmake_uncrustify-0.12.1.ebuild6
-rw-r--r--dev-ros/ament_cmake_uncrustify/ament_cmake_uncrustify-9999.ebuild8
3 files changed, 11 insertions, 11 deletions
diff --git a/dev-ros/ament_cmake_uncrustify/ament_cmake_uncrustify-0.11.2.ebuild b/dev-ros/ament_cmake_uncrustify/ament_cmake_uncrustify-0.11.2.ebuild
index 826f45045e89..ca275536e31d 100644
--- a/dev-ros/ament_cmake_uncrustify/ament_cmake_uncrustify-0.11.2.ebuild
+++ b/dev-ros/ament_cmake_uncrustify/ament_cmake_uncrustify-0.11.2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 2019-2021 Gentoo Authors
+# Copyright 2019-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -45,9 +45,9 @@ BDEPEND="
"
python_check_deps() {
- { use !test || has_version -b "dev-ros/ament_copyright[${PYTHON_USEDEP}]"; } && \
- has_version -b "dev-python/catkin_pkg[${PYTHON_USEDEP}]" && \
- has_version -b "dev-python/ament_package[${PYTHON_USEDEP}]"
+ { use !test || python_has_version "dev-ros/ament_copyright[${PYTHON_USEDEP}]"; } && \
+ python_has_version "dev-python/catkin_pkg[${PYTHON_USEDEP}]" \
+ "dev-python/ament_package[${PYTHON_USEDEP}]"
}
src_configure() {
diff --git a/dev-ros/ament_cmake_uncrustify/ament_cmake_uncrustify-0.12.1.ebuild b/dev-ros/ament_cmake_uncrustify/ament_cmake_uncrustify-0.12.1.ebuild
index c2d582d94104..ca275536e31d 100644
--- a/dev-ros/ament_cmake_uncrustify/ament_cmake_uncrustify-0.12.1.ebuild
+++ b/dev-ros/ament_cmake_uncrustify/ament_cmake_uncrustify-0.12.1.ebuild
@@ -45,9 +45,9 @@ BDEPEND="
"
python_check_deps() {
- { use !test || has_version -b "dev-ros/ament_copyright[${PYTHON_USEDEP}]"; } && \
- has_version -b "dev-python/catkin_pkg[${PYTHON_USEDEP}]" && \
- has_version -b "dev-python/ament_package[${PYTHON_USEDEP}]"
+ { use !test || python_has_version "dev-ros/ament_copyright[${PYTHON_USEDEP}]"; } && \
+ python_has_version "dev-python/catkin_pkg[${PYTHON_USEDEP}]" \
+ "dev-python/ament_package[${PYTHON_USEDEP}]"
}
src_configure() {
diff --git a/dev-ros/ament_cmake_uncrustify/ament_cmake_uncrustify-9999.ebuild b/dev-ros/ament_cmake_uncrustify/ament_cmake_uncrustify-9999.ebuild
index 826f45045e89..ca275536e31d 100644
--- a/dev-ros/ament_cmake_uncrustify/ament_cmake_uncrustify-9999.ebuild
+++ b/dev-ros/ament_cmake_uncrustify/ament_cmake_uncrustify-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 2019-2021 Gentoo Authors
+# Copyright 2019-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -45,9 +45,9 @@ BDEPEND="
"
python_check_deps() {
- { use !test || has_version -b "dev-ros/ament_copyright[${PYTHON_USEDEP}]"; } && \
- has_version -b "dev-python/catkin_pkg[${PYTHON_USEDEP}]" && \
- has_version -b "dev-python/ament_package[${PYTHON_USEDEP}]"
+ { use !test || python_has_version "dev-ros/ament_copyright[${PYTHON_USEDEP}]"; } && \
+ python_has_version "dev-python/catkin_pkg[${PYTHON_USEDEP}]" \
+ "dev-python/ament_package[${PYTHON_USEDEP}]"
}
src_configure() {