summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2016-01-19 11:47:12 +0100
committerAlexis Ballier <aballier@gentoo.org>2016-01-19 12:35:24 +0100
commite1dcb4464eb06001e39d90136646487f2ecff1e7 (patch)
tree8bf247037e3115a54d84224b86df8caadf193eb0 /dev-ros/polled_camera/polled_camera-1.11.9.ebuild
parentdev-ros/image_transport: Bump to 1.11.9. (diff)
downloadgentoo-e1dcb4464eb06001e39d90136646487f2ecff1e7.tar.gz
gentoo-e1dcb4464eb06001e39d90136646487f2ecff1e7.tar.bz2
gentoo-e1dcb4464eb06001e39d90136646487f2ecff1e7.zip
dev-ros/polled_camera: Bump to 1.11.9.
Package-Manager: portage-2.2.27 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ros/polled_camera/polled_camera-1.11.9.ebuild')
-rw-r--r--dev-ros/polled_camera/polled_camera-1.11.9.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-ros/polled_camera/polled_camera-1.11.9.ebuild b/dev-ros/polled_camera/polled_camera-1.11.9.ebuild
new file mode 100644
index 000000000000..825bf06a313d
--- /dev/null
+++ b/dev-ros/polled_camera/polled_camera-1.11.9.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros-perception/image_common"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=${PN}
+CATKIN_HAS_MESSAGES=yes
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+CATKIN_MESSAGES_TRANSITIVE_DEPS="dev-ros/std_msgs dev-ros/sensor_msgs"
+
+inherit ros-catkin
+
+DESCRIPTION="C++ helper classes for implementing a polled camera driver node and requesting images from it"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/roscpp
+ dev-ros/image_transport
+ dev-ros/rosconsole
+"
+DEPEND="${RDEPEND}"