summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2021-08-06 15:15:34 +0200
committerAlexis Ballier <aballier@gentoo.org>2021-08-06 15:30:09 +0200
commitde8c918467c5e97a7f6ce63da4db6c6d34130038 (patch)
treeb7e50814e2d91adee4e772074ac156797ed74edb /dev-ros/mavros
parentdev-ros/libmavconn: Bump to 1.8.0. (diff)
downloadgentoo-de8c918467c5e97a7f6ce63da4db6c6d34130038.tar.gz
gentoo-de8c918467c5e97a7f6ce63da4db6c6d34130038.tar.bz2
gentoo-de8c918467c5e97a7f6ce63da4db6c6d34130038.zip
dev-ros/mavros: Bump to 1.8.0.
Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ros/mavros')
-rw-r--r--dev-ros/mavros/Manifest1
-rw-r--r--dev-ros/mavros/mavros-1.8.0.ebuild40
2 files changed, 41 insertions, 0 deletions
diff --git a/dev-ros/mavros/Manifest b/dev-ros/mavros/Manifest
index b223444fdf93..720e19da7479 100644
--- a/dev-ros/mavros/Manifest
+++ b/dev-ros/mavros/Manifest
@@ -1 +1,2 @@
DIST mavros-1.5.2.tar.gz 319006 BLAKE2B 7ae349460f6edd44c716776dacb1014248f2d03fe0aad0a79e832091311f6e553cea714588099e70f3e1b0d8f4ba6a415e7e2554d5a8dedaae537a1955037cb4 SHA512 67aed9c6ef55c486008e1ee7125367f4ec1a6536cc7f28548c3434617a8a7429dd56a4f17af7dbe4678a8499ef69b57d72d4453fd5a2e54d9600b945314d1316
+DIST mavros-1.8.0.tar.gz 330619 BLAKE2B 54b1e925148370a85dc0efdc53447a6443ff5b291e656514df8046ca60b8aa7658ca77dc7731718f5e818fbbcf4631067cb03371d85e8bab95a907ca857a85ee SHA512 e9a0a51480ca45112da98d51e16b2ccc2825acab8a34074ba456d7e760cb2fe6bfd9a37e33fc1dfc6c1b072865fd180aff8e7918788ded95c7776a465cda4da2
diff --git a/dev-ros/mavros/mavros-1.8.0.ebuild b/dev-ros/mavros/mavros-1.8.0.ebuild
new file mode 100644
index 000000000000..b2927fcf9bd2
--- /dev/null
+++ b/dev-ros/mavros/mavros-1.8.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+ROS_REPO_URI="https://github.com/mavlink/mavros"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="MAVLink extendable communication node for ROS"
+LICENSE="GPL-3 LGPL-3 BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/diagnostic_updater
+ dev-ros/pluginlib
+ dev-libs/tinyxml2:=
+ dev-ros/roscpp
+ dev-ros/tf
+ dev-ros/angles
+ dev-ros/libmavconn
+ dev-ros/rosconsole_bridge
+ dev-libs/boost:=
+ dev-ros/eigen_conversions
+ sci-geosciences/GeographicLib
+ >=dev-ros/mavlink-gbp-release-2020.9.10
+ dev-libs/console_bridge:=
+"
+DEPEND="${RDEPEND}
+ dev-ros/std_srvs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ >=dev-ros/mavros_msgs-${PV}[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/diagnostic_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/sensor_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/std_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/geometry_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/nav_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/trajectory_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+"