summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2017-04-26 19:13:42 +0200
committerAlexis Ballier <aballier@gentoo.org>2017-04-26 19:29:29 +0200
commit150802008423ebdd5fd3fc3afaf6af8076d98dad (patch)
tree80a160704e9784a83c42509493663fbc4fcba555 /dev-ros/diagnostic_analysis/diagnostic_analysis-1.9.0.ebuild
parentdev-ros/diagnostic_aggregator: Bump to 1.9.0. (diff)
downloadgentoo-150802008423ebdd5fd3fc3afaf6af8076d98dad.tar.gz
gentoo-150802008423ebdd5fd3fc3afaf6af8076d98dad.tar.bz2
gentoo-150802008423ebdd5fd3fc3afaf6af8076d98dad.zip
dev-ros/diagnostic_analysis: Bump to 1.9.0.
Package-Manager: Portage-2.3.5, Repoman-2.3.2
Diffstat (limited to 'dev-ros/diagnostic_analysis/diagnostic_analysis-1.9.0.ebuild')
-rw-r--r--dev-ros/diagnostic_analysis/diagnostic_analysis-1.9.0.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-ros/diagnostic_analysis/diagnostic_analysis-1.9.0.ebuild b/dev-ros/diagnostic_analysis/diagnostic_analysis-1.9.0.ebuild
new file mode 100644
index 000000000000..b2b767204efd
--- /dev/null
+++ b/dev-ros/diagnostic_analysis/diagnostic_analysis-1.9.0.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros/diagnostics"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=${PN}
+PYTHON_COMPAT=( python2_7 )
+
+inherit ros-catkin
+
+DESCRIPTION="Converts diagnostics data into a series of CSV files"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/diagnostic_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
+ dev-ros/roslib[${PYTHON_USEDEP}]
+ dev-ros/rosbag[${PYTHON_USEDEP}]
+ dev-ros/rostest[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )"