summaryrefslogtreecommitdiff
path: root/dev-qt
diff options
context:
space:
mode:
authorJimi Huotari <chiitoo@gentoo.org>2023-03-19 13:25:37 +0200
committerJimi Huotari <chiitoo@gentoo.org>2023-03-19 15:06:38 +0200
commit1fdd392de323a402296270b42dcc8fcae6e9d4cf (patch)
tree17e9de032484e75c0382fa347e4b7f431899f192 /dev-qt
parentdev-qt/qtsvg: add 6.4.3 (diff)
downloadgentoo-1fdd392de323a402296270b42dcc8fcae6e9d4cf.tar.gz
gentoo-1fdd392de323a402296270b42dcc8fcae6e9d4cf.tar.bz2
gentoo-1fdd392de323a402296270b42dcc8fcae6e9d4cf.zip
dev-qt/qttools: add 6.4.3
Signed-off-by: Jimi Huotari <chiitoo@gentoo.org>
Diffstat (limited to 'dev-qt')
-rw-r--r--dev-qt/qttools/Manifest1
-rw-r--r--dev-qt/qttools/qttools-6.4.3.ebuild66
2 files changed, 67 insertions, 0 deletions
diff --git a/dev-qt/qttools/Manifest b/dev-qt/qttools/Manifest
index f2c0952ad660..4580159b7314 100644
--- a/dev-qt/qttools/Manifest
+++ b/dev-qt/qttools/Manifest
@@ -1 +1,2 @@
DIST qttools-everywhere-src-6.4.2.tar.xz 8740276 BLAKE2B ea376587d3385afa620c917dbf06d3f9a8303f19388f001ae0e441ce392ae401f80893a788b3a4162575913046d922f7c9606cec85d6786860190c4b996ab201 SHA512 303da2e7d58d213b8a5d4f4e36c7903b57ea8011f711cfb598b79414a6da1e3cc5e47a26a34ff1bdf82e07cb4f5274bd45297b880c380e6a3de3df42837a2c2c
+DIST qttools-everywhere-src-6.4.3.tar.xz 8738280 BLAKE2B 3da253fabc4025f36ef6a0a0a946b026288d5bc921794ecb9dd71a51113ca067ad7dc2b4f4ff85bb75f999d06639f8c9b85e3139d045ee46aaa05fc432285033 SHA512 24dc02b760d4b1640eac539c9d0dfff9fe516332e5932f43456140daa3044c1e748731a883cc4f80e94626602241d040341e2af27efd470e7d6f50a908660382
diff --git a/dev-qt/qttools/qttools-6.4.3.ebuild b/dev-qt/qttools/qttools-6.4.3.ebuild
new file mode 100644
index 000000000000..197390961888
--- /dev/null
+++ b/dev-qt/qttools/qttools-6.4.3.ebuild
@@ -0,0 +1,66 @@
+# Copyright 2021-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit qt6-build
+
+DESCRIPTION="Qt Tools Collection"
+
+if [[ ${QT6_BUILD_TYPE} == release ]]; then
+ KEYWORDS="~amd64"
+fi
+
+IUSE="
+ assistant designer distancefieldgenerator +linguist pixeltool
+ qdbus qdoc qtattributionsscanner qtdiag qtplugininfo
+"
+
+DEPEND="
+ =dev-qt/qtbase-${PV}*[network]
+ assistant? ( =dev-qt/qtbase-${PV}*[sql,widgets] )
+ designer? ( =dev-qt/qtbase-${PV}*[widgets] )
+ distancefieldgenerator? (
+ =dev-qt/qtbase-${PV}*[widgets]
+ =dev-qt/qtdeclarative-${PV}*
+ )
+ pixeltool? ( =dev-qt/qtbase-${PV}*[widgets] )
+ qdbus? ( =dev-qt/qtbase-${PV}*[widgets] )
+ qdoc? ( sys-devel/clang:= )
+ qtdiag? ( =dev-qt/qtbase-${PV}*[opengl,widgets] )
+"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ local mycmakeargs=(
+ $(qt_feature assistant)
+ -DQT_FEATURE_commandlineparser=ON
+ $(qt_feature designer)
+ $(qt_feature distancefieldgenerator)
+ $(qt_feature linguist)
+ $(qt_feature pixeltool)
+ $(qt_feature qdbus)
+ $(qt_feature qdoc clang)
+ $(qt_feature qtattributionsscanner)
+ $(qt_feature qtdiag)
+ $(qt_feature qtplugininfo)
+ -DQT_FEATURE_thread=ON
+ )
+
+ qt6-build_src_configure
+}
+
+src_install() {
+ qt6-build_src_install
+
+ use assistant && qt6_symlink_binary_to_path assistant 6
+ use designer && qt6_symlink_binary_to_path designer 6
+ use distancefieldgenerator && qt6_symlink_binary_to_path qdistancefieldgenerator 6
+ use linguist && qt6_symlink_binary_to_path linguist 6
+ use pixeltool && qt6_symlink_binary_to_path pixeltool 6
+ use qdbus && qt6_symlink_binary_to_path qdbus 6
+ use qdbus && qt6_symlink_binary_to_path qdbusviewer 6
+ use qdoc && qt6_symlink_binary_to_path qdoc 6
+ use qtdiag && qt6_symlink_binary_to_path qtdiag 6
+ use qtplugininfo && qt6_symlink_binary_to_path qtplugininfo 6
+}