summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/xlsxwriter
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/xlsxwriter')
-rw-r--r--dev-python/xlsxwriter/Manifest1
-rw-r--r--dev-python/xlsxwriter/metadata.xml9
-rw-r--r--dev-python/xlsxwriter/xlsxwriter-0.7.3.ebuild33
3 files changed, 43 insertions, 0 deletions
diff --git a/dev-python/xlsxwriter/Manifest b/dev-python/xlsxwriter/Manifest
new file mode 100644
index 000000000000..036cc3423eb8
--- /dev/null
+++ b/dev-python/xlsxwriter/Manifest
@@ -0,0 +1 @@
+DIST XlsxWriter-0.7.3.tar.gz 231999 SHA256 2fa0f2d633bfbbc55a48abd4089820c744ed7a40e11c5c1580196a2c129eb8c6 SHA512 b85ef49fb6d5c6a6454292a7cdbc3fdff9674578f2e535aab7b08f671180f59934616fd78e89e007e8a662539dbbd9b0b9571b02df049a0e5f70f706d9acde35 WHIRLPOOL 7124119bd0151c76689b08fd4da74b5e5876f1047cbd63c960ff7728ed70bcc82ebcf1c44f4c08a4fe5ddcb9aca6441a5c428eab5f793028e3ef65ba3494ec85
diff --git a/dev-python/xlsxwriter/metadata.xml b/dev-python/xlsxwriter/metadata.xml
new file mode 100644
index 000000000000..6955a1f97fe1
--- /dev/null
+++ b/dev-python/xlsxwriter/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>python</herd>
+ <upstream>
+ <remote-id type="pypi">XlsxWriter</remote-id>
+ <remote-id type="github">jmcnamara/XlsxWriter</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/xlsxwriter/xlsxwriter-0.7.3.ebuild b/dev-python/xlsxwriter/xlsxwriter-0.7.3.ebuild
new file mode 100644
index 000000000000..214958d30cf8
--- /dev/null
+++ b/dev-python/xlsxwriter/xlsxwriter-0.7.3.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{3,4} pypy pypy3 )
+
+inherit distutils-r1
+
+MY_PN="XlsxWriter"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Python module for creating Excel XLSX files"
+HOMEPAGE="https://pypi.python.org/pypi/XlsxWriter https://github.com/jmcnamara/XlsxWriter"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+SLOT="0"
+LICENSE="BSD"
+KEYWORDS="amd64 x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )
+"
+
+S="${WORKDIR}"/${MY_P}
+
+python_test() {
+ nosetests --verbosity=3 || die
+}