summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSébastien Fabbro <bicatali@gentoo.org>2016-02-22 21:48:03 +0000
committerSébastien Fabbro <bicatali@gentoo.org>2016-02-22 21:48:20 +0000
commit51c36f98fa12a844637a5cee0dfa776999e93ff9 (patch)
treec1ccd8cbc7151599a08386b6655e6708555b7a67 /dev-python/wcsaxes
parentmate-base/mate: Update to use new mate-themes-meta (diff)
downloadgentoo-51c36f98fa12a844637a5cee0dfa776999e93ff9.tar.gz
gentoo-51c36f98fa12a844637a5cee0dfa776999e93ff9.tar.bz2
gentoo-51c36f98fa12a844637a5cee0dfa776999e93ff9.zip
dev-python/wcsaxes: version bump
Package-Manager: portage-2.2.27
Diffstat (limited to 'dev-python/wcsaxes')
-rw-r--r--dev-python/wcsaxes/Manifest1
-rw-r--r--dev-python/wcsaxes/files/wcsaxes-0.6-disable_mpltest.patch14
-rw-r--r--dev-python/wcsaxes/files/wcsaxes-0.6-disable_numpy_warnings_test.patch16
-rw-r--r--dev-python/wcsaxes/wcsaxes-0.6.ebuild48
4 files changed, 79 insertions, 0 deletions
diff --git a/dev-python/wcsaxes/Manifest b/dev-python/wcsaxes/Manifest
index df3441cbc88b..2ba5a5830302 100644
--- a/dev-python/wcsaxes/Manifest
+++ b/dev-python/wcsaxes/Manifest
@@ -1 +1,2 @@
DIST wcsaxes-0.3.tar.gz 773984 SHA256 012861678afa3c05700c4dd94a73bbd0534dae7ef8d9dc215fb01d6e5a60477f SHA512 597494609e2add782dcf84a6163b7093d1a467ffb6321d6d25064f9f87dcb0f7e5e076818b0707b9f10d0894a26ce240cda9598f035364832efe57d6ec51d76a WHIRLPOOL 1d05ce40460a2477c43107f33a68de08cdeb66ee395d3311ee74c9e7d354b675584f3e5d79ea91303a1808ab767df6f54bb5c65993009edfa67b416057c459fe
+DIST wcsaxes-0.6.tar.gz 617882 SHA256 ab8101ff742ebba79da3ff7bf777f24fcf8275886dbb5482f0a2eb3ab6756ee4 SHA512 6254fabc31b7c2e44dd86b0330592e01a688e36957e9d96348f7b4d305242e02e27d2363fd7ada37ad6dba292c66bbace9ea675f475388ed5545ac24cad1226c WHIRLPOOL e2f1d7b230fb7ba3982915638535258377fd450d47f3f191ba0a12aa1698050213353e315de2329e3f8ad359a76bfccdc4291e49eb6b0a4947d0f41305977100
diff --git a/dev-python/wcsaxes/files/wcsaxes-0.6-disable_mpltest.patch b/dev-python/wcsaxes/files/wcsaxes-0.6-disable_mpltest.patch
new file mode 100644
index 000000000000..b62e15a44569
--- /dev/null
+++ b/dev-python/wcsaxes/files/wcsaxes-0.6-disable_mpltest.patch
@@ -0,0 +1,14 @@
+Author: Ole Streicher <olebole@debian.org>
+Description: Remove the tests that require pytest-mpl
+ Pytest_mpl is (still) not available in Debian.
+ https://github.com/astrofrog/pytest-mpl
+--- a/setup.cfg
++++ b/setup.cfg
+@@ -11,7 +11,6 @@
+ minversion = 2.2
+ norecursedirs = build docs/_build
+ doctest_plus = enabled
+-addopts = --mpl --mpl-baseline-path=wcsaxes/tests/baseline_images
+
+ [ah_bootstrap]
+ auto_use = False
diff --git a/dev-python/wcsaxes/files/wcsaxes-0.6-disable_numpy_warnings_test.patch b/dev-python/wcsaxes/files/wcsaxes-0.6-disable_numpy_warnings_test.patch
new file mode 100644
index 000000000000..ff6567c48f94
--- /dev/null
+++ b/dev-python/wcsaxes/files/wcsaxes-0.6-disable_numpy_warnings_test.patch
@@ -0,0 +1,16 @@
+Author: Ole Streicher <olebole@debian.org>
+Description: Disable test_no_numpy_warnings
+ This test may fails when numpy decides that it wants to put some important
+ message as a warning; even if nothing goes wrong. This happens f.e. for
+ numpy-1.11.0~b2.
+--- a/wcsaxes/tests/test_misc.py
++++ b/wcsaxes/tests/test_misc.py
+@@ -51,6 +51,8 @@
+ COORDSYS= 'icrs '
+ """, sep='\n')
+
++# see https://github.com/astrofrog/wcsaxes/issues/187
++@pytest.mark.xfail
+ def test_no_numpy_warnings():
+
+ # Make sure that no warnings are raised if some pixels are outside WCS
diff --git a/dev-python/wcsaxes/wcsaxes-0.6.ebuild b/dev-python/wcsaxes/wcsaxes-0.6.ebuild
new file mode 100644
index 000000000000..67bda681b879
--- /dev/null
+++ b/dev-python/wcsaxes/wcsaxes-0.6.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+PYTHON_COMPAT=( python{2_7,3_4,3_5} )
+
+inherit distutils-r1 virtualx
+
+DESCRIPTION="Framework for plotting astronomical and geospatial data"
+HOMEPAGE="http://wcsaxes.readthedocs.org"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~x86-fbsd ~amd64-linux ~x86-linux"
+IUSE="doc test"
+
+RDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/astropy[${PYTHON_USEDEP}]
+ dev-python/matplotlib[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}]
+ dev-python/sphinx_rtd_theme[${PYTHON_USEDEP}] )
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-0.6-disable_mpltest.patch"
+ "${FILESDIR}/${PN}-0.6-disable_numpy_warnings_test.patch"
+)
+
+python_prepare_all() {
+ sed -i -e '/auto_use/s/True/False/' setup.cfg || die
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ use doc && esetup.py build_sphinx -w
+}
+
+python_test() {
+ virtx esetup.py test
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/_build/html/ )
+ distutils-r1_python_install_all
+}