summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-09-09 23:10:37 +0200
committerMichał Górny <mgorny@gentoo.org>2021-09-09 23:10:37 +0200
commit58da3008ba6c3fba9addfc403956101b8cad9be3 (patch)
tree96d3305f362d5ced5ac141c1bef04cad689ec4de /dev-python/tekore
parentapp-admin/awscli: Bump to 1.20.39 (diff)
downloadgentoo-58da3008ba6c3fba9addfc403956101b8cad9be3.tar.gz
gentoo-58da3008ba6c3fba9addfc403956101b8cad9be3.tar.bz2
gentoo-58da3008ba6c3fba9addfc403956101b8cad9be3.zip
dev-python/tekore: Bump to 4.0.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/tekore')
-rw-r--r--dev-python/tekore/Manifest1
-rw-r--r--dev-python/tekore/tekore-4.0.0.ebuild40
2 files changed, 41 insertions, 0 deletions
diff --git a/dev-python/tekore/Manifest b/dev-python/tekore/Manifest
index 18eb751ff376..d12017d7dc63 100644
--- a/dev-python/tekore/Manifest
+++ b/dev-python/tekore/Manifest
@@ -1 +1,2 @@
DIST tekore-3.7.1.tar.gz 258235 BLAKE2B e04edfab294ac3dac1fb086f296bf3fcc463cdad981d435fdd19ec812f1bb2ff79cacaa94d5105dc1070dd56602cc9a502537c68020cb27b2eb5b3c93788f193 SHA512 ed315a0b5b071265d2ba12d996bedafdea87286fd1beecc14d247176f2bdd2245e0220fb186ce4bd6eec2bc13a764f74b067ce1e546d8c30e618a4bdc3bf02e0
+DIST tekore-4.0.0.tar.gz 259755 BLAKE2B 5c4c990c14187c20ef3566d1bc0cf32e50fe108d90b59126e2d56105b6fe053ca02c98e7ad7a4fa09345792106e956873a0f42b8492420bd74898557c6d97f23 SHA512 7e5cf6044a6a7045257b9b9830fe4bdb6fb175240b295da3f93cb0557150536655ddf44ab551b52182815fc517b8e43ee704b1061db1284426574e741f7d9a56
diff --git a/dev-python/tekore/tekore-4.0.0.ebuild b/dev-python/tekore/tekore-4.0.0.ebuild
new file mode 100644
index 000000000000..fd70d3d6296c
--- /dev/null
+++ b/dev-python/tekore/tekore-4.0.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="Spotify Web API client"
+HOMEPAGE="
+ https://tekore.readthedocs.io
+ https://github.com/felix-hilden/tekore
+"
+SRC_URI="https://github.com/felix-hilden/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+KEYWORDS="~amd64"
+SLOT="0"
+
+RDEPEND="
+ <dev-python/httpx-0.20[${PYTHON_USEDEP}]
+"
+
+BDEPEND="
+ test? (
+ >=dev-python/pytest-asyncio-0.11[${PYTHON_USEDEP}]
+ )
+"
+
+DOCS=( readme.rst )
+
+distutils_enable_tests pytest
+distutils_enable_sphinx docs/src \
+ dev-python/sphinx_rtd_theme \
+ dev-python/sphinx-autodoc-typehints
+
+EPYTEST_DESELECT=(
+ # Internet
+ tests/auth/expiring.py::TestCredentialsOnline::test_bad_arguments_raises_error
+)