summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-03-07 17:22:50 +0100
committerMichał Górny <mgorny@gentoo.org>2024-03-07 17:22:50 +0100
commitff08975682be996a08b18d05045dccc288dadad1 (patch)
tree1b89f0f1805456307a41192547296f21ba84a6b1 /dev-python/requests-cache
parentdev-python/pytest-jupyter: Remove old (diff)
downloadgentoo-ff08975682be996a08b18d05045dccc288dadad1.tar.gz
gentoo-ff08975682be996a08b18d05045dccc288dadad1.tar.bz2
gentoo-ff08975682be996a08b18d05045dccc288dadad1.zip
dev-python/requests-cache: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/requests-cache')
-rw-r--r--dev-python/requests-cache/Manifest1
-rw-r--r--dev-python/requests-cache/requests-cache-1.1.1.ebuild92
2 files changed, 0 insertions, 93 deletions
diff --git a/dev-python/requests-cache/Manifest b/dev-python/requests-cache/Manifest
index 75355cf16a77..0a170bdc4a9b 100644
--- a/dev-python/requests-cache/Manifest
+++ b/dev-python/requests-cache/Manifest
@@ -1,2 +1 @@
-DIST requests-cache-1.1.1.gh.tar.gz 2927360 BLAKE2B 2db8b71d4f219f2b61e4477a57af9dee09783ea47e86dfcc7b7726acb2507043186433ee6a9f67162c0a01c5f1439fd52ea9b74b89daa94cbe351341ef6b1f53 SHA512 99782fe635daa0834709b254b0d51c5d2b2ad37d26201acdc143f963b613bb6b4e5863e2246a2bf9d099c773e229157a983b04a40740e6207e2c356dc48bdba6
DIST requests-cache-1.2.0.gh.tar.gz 3057187 BLAKE2B 135d39d8fac1e123c71b07b30002b980b5fdcdb586cafb310f8f72e865cdc97f62b699cd981068207c6f020deef595469801d440cf5034566e9618385d569437 SHA512 b198d282cfd656c432d3a63f4d615191ac1ff97c9563e9bd6945e7a78444601108beb47a0f4a79740c7bd6942c3753f025cd52457e87ece7964229799bbb8fa1
diff --git a/dev-python/requests-cache/requests-cache-1.1.1.ebuild b/dev-python/requests-cache/requests-cache-1.1.1.ebuild
deleted file mode 100644
index 49a50a7aedeb..000000000000
--- a/dev-python/requests-cache/requests-cache-1.1.1.ebuild
+++ /dev/null
@@ -1,92 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=poetry
-PYTHON_COMPAT=( pypy3 python3_{10..12} )
-PYTHON_REQ_USE="sqlite"
-
-inherit distutils-r1 optfeature
-
-HOMEPAGE="
- https://pypi.org/project/requests-cache/
- https://github.com/requests-cache/requests-cache/
-"
-DESCRIPTION="Persistent cache for requests library"
-SRC_URI="
- https://github.com/requests-cache/requests-cache/archive/v${PV}.tar.gz
- -> ${P}.gh.tar.gz
-"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 arm arm64 ~loong ppc64 ~riscv x86"
-
-RDEPEND="
- dev-python/attrs[${PYTHON_USEDEP}]
- >=dev-python/cattrs-22.2[${PYTHON_USEDEP}]
- >=dev-python/platformdirs-2.5[${PYTHON_USEDEP}]
- >=dev-python/requests-2.0.0[${PYTHON_USEDEP}]
- dev-python/urllib3[${PYTHON_USEDEP}]
- >=dev-python/url-normalize-1.4[${PYTHON_USEDEP}]
-"
-BDEPEND="
- test? (
- dev-python/itsdangerous[${PYTHON_USEDEP}]
- dev-python/pytest-httpbin[${PYTHON_USEDEP}]
- dev-python/requests-mock[${PYTHON_USEDEP}]
- dev-python/responses[${PYTHON_USEDEP}]
- >=dev-python/rich-10.0[${PYTHON_USEDEP}]
- dev-python/timeout-decorator[${PYTHON_USEDEP}]
- >=dev-python/ujson-5.4[${PYTHON_USEDEP}]
- $(python_gen_cond_dep '
- dev-python/time-machine[${PYTHON_USEDEP}]
- ' 'python*')
- )
-"
-
-distutils_enable_tests pytest
-
-python_test() {
- local EPYTEST_IGNORE=(
- # These require extra servers running
- tests/integration/test_dynamodb.py
- tests/integration/test_gridfs.py
- tests/integration/test_mongodb.py
- tests/integration/test_redis.py
- )
- local EPYTEST_DESELECT=(
- # Requires Internet access
- tests/integration/test_upgrade.py::test_version_upgrade
- )
-
- case ${EPYTHON} in
- pypy3)
- EPYTEST_DESELECT+=(
- # "database is locked", upstream probably relies on GC
- # too much
- tests/integration/test_sqlite.py
- )
- ;;
- python3.12)
- # https://github.com/requests-cache/requests-cache/issues/845
- EPYTEST_DESELECT+=(
- tests/integration/test_memory.py::TestMemoryCache::test_response_no_duplicate_read
- tests/integration/test_sqlite.py::TestSQLiteCache::test_concurrency
- )
- ;;
- esac
-
- local -x USE_PYTEST_HTTPBIN=true
- epytest
-}
-
-pkg_postinst() {
- optfeature "redis backend" "dev-python/redis"
- optfeature "MongoDB backend" "dev-python/pymongo"
-
- optfeature "JSON serialization" "dev-python/ujson"
- optfeature "YAML serialization" "dev-python/pyyaml"
- optfeature "signing serialized data" "dev-python/itsdangerous"
-}