summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2023-04-28 18:57:14 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2023-04-28 18:57:14 +0300
commit0dcbd065d72b245dd8cb0a1129765ed97f71f7de (patch)
tree4e89a398b2ae6bd57ccf88a2e63a8a7756ff3968 /dev-python/requests-cache
parentdev-python/zope-i18nmessageid: drop 5.1.1, 6.0.0 (diff)
downloadgentoo-0dcbd065d72b245dd8cb0a1129765ed97f71f7de.tar.gz
gentoo-0dcbd065d72b245dd8cb0a1129765ed97f71f7de.tar.bz2
gentoo-0dcbd065d72b245dd8cb0a1129765ed97f71f7de.zip
dev-python/requests-cache: drop 1.0.0
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python/requests-cache')
-rw-r--r--dev-python/requests-cache/Manifest1
-rw-r--r--dev-python/requests-cache/requests-cache-1.0.0.ebuild72
2 files changed, 0 insertions, 73 deletions
diff --git a/dev-python/requests-cache/Manifest b/dev-python/requests-cache/Manifest
index 33918c670671..5c29309222ca 100644
--- a/dev-python/requests-cache/Manifest
+++ b/dev-python/requests-cache/Manifest
@@ -1,2 +1 @@
-DIST requests-cache-1.0.0.gh.tar.gz 2914633 BLAKE2B 5402d3b6bc99bb0b72a484854b83450d8f57fd0aff39661d6f2452c69cc0ca9b140fd2ac7b02110e47bcc0bf2497c58912330d7472b9f1701b8d4e2a54f7cef7 SHA512 92d6e1b9afb158f824a4b20d83c7b30a5988476b741213b0663df6095df1753da2dcd6516372ba383864e19d346850a356e9370b2ae27554effcc3f0b6a078c8
DIST requests-cache-1.0.1.gh.tar.gz 2914175 BLAKE2B b1c3c544a761e127204172381a66b0175f09e49040a7d0f04760cf03b253846ac7e831b7c15d4b128e47e5bc132ea3493eba2784ac442be4dc0eab262e2251b0 SHA512 ec5788e31f60fd95e575d01af1163f981757972db6557d7a62da2ca0719e84262cf66cdd9b40c73cca540b92d6b7f6beba1aa42bedba528734c61edf5013ec3d
diff --git a/dev-python/requests-cache/requests-cache-1.0.0.ebuild b/dev-python/requests-cache/requests-cache-1.0.0.ebuild
deleted file mode 100644
index f5990c646567..000000000000
--- a/dev-python/requests-cache/requests-cache-1.0.0.ebuild
+++ /dev/null
@@ -1,72 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=poetry
-PYTHON_COMPAT=( python3_{9..11} )
-PYTHON_REQ_USE="sqlite"
-
-inherit distutils-r1 optfeature
-
-HOMEPAGE="
- https://pypi.org/project/requests-cache/
- https://github.com/requests-cache/requests-cache/
-"
-DESCRIPTION="Persistent cache for requests library"
-SRC_URI="
- https://github.com/requests-cache/requests-cache/archive/v${PV}.tar.gz
- -> ${P}.gh.tar.gz
-"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 x86"
-
-RDEPEND="
- dev-python/attrs[${PYTHON_USEDEP}]
- >=dev-python/cattrs-22.2[${PYTHON_USEDEP}]
- >=dev-python/platformdirs-2.5[${PYTHON_USEDEP}]
- >=dev-python/requests-2.0.0[${PYTHON_USEDEP}]
- dev-python/urllib3[${PYTHON_USEDEP}]
- >=dev-python/url-normalize-1.4[${PYTHON_USEDEP}]
-"
-BDEPEND="
- test? (
- dev-python/itsdangerous[${PYTHON_USEDEP}]
- dev-python/pytest-httpbin[${PYTHON_USEDEP}]
- dev-python/requests-mock[${PYTHON_USEDEP}]
- dev-python/responses[${PYTHON_USEDEP}]
- >=dev-python/rich-10.0[${PYTHON_USEDEP}]
- dev-python/timeout-decorator[${PYTHON_USEDEP}]
- >=dev-python/ujson-5.4[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-
-python_test() {
- local EPYTEST_IGNORE=(
- # These require extra servers running
- tests/integration/test_dynamodb.py
- tests/integration/test_gridfs.py
- tests/integration/test_mongodb.py
- tests/integration/test_redis.py
- )
- local EPYTEST_DESELECT=(
- # Requires Internet access
- tests/integration/test_upgrade.py::test_version_upgrade
- )
-
- local -x USE_PYTEST_HTTPBIN=true
- epytest
-}
-
-pkg_postinst() {
- optfeature "redis backend" "dev-python/redis"
- optfeature "MongoDB backend" "dev-python/pymongo"
-
- optfeature "JSON serialization" "dev-python/ujson"
- optfeature "YAML serialization" "dev-python/pyyaml"
- optfeature "signing serialized data" "dev-python/itsdangerous"
-}