summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPetr Vaněk <arkamar@gentoo.org>2024-07-21 15:46:28 +0200
committerPetr Vaněk <arkamar@gentoo.org>2024-07-21 15:47:13 +0200
commitd0d564be10fffa37a364b7601d6ad85b8812b4f1 (patch)
treed656b9484f911fd6e7b078d07f4517053a6a2787 /dev-python/pure-eval
parentkernel-build.eclass: don't check key/cert if merging binary (diff)
downloadgentoo-d0d564be10fffa37a364b7601d6ad85b8812b4f1.tar.gz
gentoo-d0d564be10fffa37a364b7601d6ad85b8812b4f1.tar.bz2
gentoo-d0d564be10fffa37a364b7601d6ad85b8812b4f1.zip
dev-python/pure-eval: add 0.2.3
Signed-off-by: Petr Vaněk <arkamar@gentoo.org>
Diffstat (limited to 'dev-python/pure-eval')
-rw-r--r--dev-python/pure-eval/Manifest1
-rw-r--r--dev-python/pure-eval/pure-eval-0.2.3.ebuild37
2 files changed, 38 insertions, 0 deletions
diff --git a/dev-python/pure-eval/Manifest b/dev-python/pure-eval/Manifest
index 2e04617fdd08..429c6ba56260 100644
--- a/dev-python/pure-eval/Manifest
+++ b/dev-python/pure-eval/Manifest
@@ -1 +1,2 @@
DIST pure_eval-0.2.2.tar.gz 19395 BLAKE2B 19f86a1436e5f1a026a24f62c435e8970d84960f4cde1de80c58949b1aede6aa7562e8430e10e3f7171212c31d5699a3321fad5fb2ea1eed961a30d43a632a79 SHA512 35d20cbbfd513b7ac341759e619401a5f57b7b9df8abd09ce6414d4ee6bfa45dcadbad7529d067e81ad7ea2107c14fd03783a3a77f8074dad30d2e5161656804
+DIST pure_eval-0.2.3.tar.gz 19752 BLAKE2B 18ed36bf045ddcd351a8dd82079df409e26ed745e3c326a7743536bc3e74a880830f55fa1252113aa03b9830b5cac63601335cb6b877994861efb0b9b54a07d9 SHA512 8575f54aa7e522a3db86b80fdbe1f8518ef4ef17a160b2541f74d0853e123cffcbc9f04df9faeddfc7ed92bb6b1d27fb7b3ce2de1c66b6b13e453b7b2bf72052
diff --git a/dev-python/pure-eval/pure-eval-0.2.3.ebuild b/dev-python/pure-eval/pure-eval-0.2.3.ebuild
new file mode 100644
index 000000000000..259f3e8412cb
--- /dev/null
+++ b/dev-python/pure-eval/pure-eval-0.2.3.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{10..13} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Safely evaluate AST nodes without side effects"
+HOMEPAGE="
+ https://github.com/alexmojaki/pure_eval/
+ https://pypi.org/project/pure-eval/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~arm64-macos ~x64-macos"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_DESELECT=()
+
+ case ${EPYTHON} in
+ pypy3)
+ EPYTEST_DESELECT+=(
+ # https://github.com/alexmojaki/pure_eval/issues/15
+ tests/test_getattr_static.py::TestGetattrStatic::test_custom_object_dict
+ tests/test_utils.py::test_safe_name_samples
+ )
+ ;;
+ esac
+
+ epytest
+}