summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@riseup.net>2020-01-15 13:57:51 +0100
committerBenda Xu <heroxbd@gentoo.org>2020-02-09 20:43:50 +0800
commit85112c6c3024d0284417621fca05373c5d389a01 (patch)
tree5b8312739ab1b6951b3d54b50cc35e96965a4e96 /dev-python/line_profiler
parentdev-python/xdoctest: A rewrite of Python's builtin doctest module (diff)
downloadgentoo-85112c6c3024d0284417621fca05373c5d389a01.tar.gz
gentoo-85112c6c3024d0284417621fca05373c5d389a01.tar.bz2
gentoo-85112c6c3024d0284417621fca05373c5d389a01.zip
dev-python/line_profiler: Version bump 3.0.2
Add py3_7 Put setuptools in rdepend Closes: https://github.com/gentoo/gentoo/pull/14344 Closes: https://bugs.gentoo.org/705872 Package-Manager: Portage-2.3.84, Repoman-2.3.20 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@riseup.net> Signed-off-by: Benda Xu <heroxbd@gentoo.org>
Diffstat (limited to 'dev-python/line_profiler')
-rw-r--r--dev-python/line_profiler/Manifest1
-rw-r--r--dev-python/line_profiler/line_profiler-3.0.2.ebuild28
-rw-r--r--dev-python/line_profiler/metadata.xml2
3 files changed, 30 insertions, 1 deletions
diff --git a/dev-python/line_profiler/Manifest b/dev-python/line_profiler/Manifest
index 3e7d57fbcc5e..43809df6ec19 100644
--- a/dev-python/line_profiler/Manifest
+++ b/dev-python/line_profiler/Manifest
@@ -1,2 +1,3 @@
DIST line_profiler-2.0.tar.gz 68478 BLAKE2B fb814b251e8f18a51e65297e57523b85c55b4060444c42d99801aa88c8ee0279abf14def6ecd5a9b09550e46e2d27b3ec809b1333725b00de64b58f117c76ed7 SHA512 c0335fc69fb47c150fa5555af4f7fdf4b172ca12ee6512e04ba854c4a81f3e6ee5594e484d11c8ea7e9e8048e3f3b8661db52332d4ac645195a0e050acea4ecb
DIST line_profiler-2.1.2.tar.gz 83131 BLAKE2B 0f61d7dbab24988a50c1c0a9dce528cf792ca53b5f4c60f00fd9dabfd3d3e109f2d245867bc1ebb8294fb84343907e3593c416341ea1b0d7ae626cda8a3218d3 SHA512 625a585915d338fe8ef2f37c5b5bc024f769a623380b85725bcf33686e4cc62a211c2e91552e093dee940367b0d2ad306c5cbe7f1e8f1574eb731d128b8e22bd
+DIST line_profiler-3.0.2.tar.gz 44005 BLAKE2B 2237eb5fc26d673eb0b7c1970b7f04ba7df1c5ebe5f1605a818dba218f9b134ddc3647ae91b10b42ad551cc8e4638d39723ac9d62f75ea705bc7ca1ddc41c99b SHA512 db6cd96c7dbab9b0d4844a3283c65dc56724d50ebe1ce439f6a2b3410e96209d812c2baf2795e2c8d78af23e3cd01c67a92aa0aca4533e8e4b661bf2e63f63c1
diff --git a/dev-python/line_profiler/line_profiler-3.0.2.ebuild b/dev-python/line_profiler/line_profiler-3.0.2.ebuild
new file mode 100644
index 000000000000..e7db155b3e30
--- /dev/null
+++ b/dev-python/line_profiler/line_profiler-3.0.2.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7} )
+
+DISTUTILS_USE_SETUPTOOLS=rdepend
+
+inherit distutils-r1
+
+DESCRIPTION="Line-by-line profiler"
+HOMEPAGE="https://github.com/pyutils/line_profiler"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="BSD"
+KEYWORDS="~amd64 ~x86"
+
+BDEPEND="dev-python/cython[${PYTHON_USEDEP}]
+ dev-python/scikit-build[${PYTHON_USEDEP}]"
+
+RDEPEND="dev-python/ipython[${PYTHON_USEDEP}]"
+
+DEPEND="test? ( dev-python/coverage[${PYTHON_USEDEP}]
+ dev-python/ubelt[${PYTHON_USEDEP}] )"
+
+distutils_enable_tests pytest
diff --git a/dev-python/line_profiler/metadata.xml b/dev-python/line_profiler/metadata.xml
index 9039f4a31310..35be66749f84 100644
--- a/dev-python/line_profiler/metadata.xml
+++ b/dev-python/line_profiler/metadata.xml
@@ -13,6 +13,6 @@
</longdescription>
<upstream>
<remote-id type="pypi">line_profiler</remote-id>
- <remote-id type="github">rkern/line_profiler</remote-id>
+ <remote-id type="github">pyutils/line_profiler</remote-id>
</upstream>
</pkgmetadata>