summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-10-30 07:18:55 +0100
committerMichał Górny <mgorny@gentoo.org>2022-10-30 07:39:04 +0100
commit23bcb3df65edacae59afdf817313da4b2c053073 (patch)
tree7c1110fda2eef19f7d0e3986bb75e1ad2f1e20f5 /dev-python/jaraco-collections
parentdev-python/httplib2: Bump to 0.21.0 (diff)
downloadgentoo-23bcb3df65edacae59afdf817313da4b2c053073.tar.gz
gentoo-23bcb3df65edacae59afdf817313da4b2c053073.tar.bz2
gentoo-23bcb3df65edacae59afdf817313da4b2c053073.zip
dev-python/jaraco-collections: Bump to 3.7.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/jaraco-collections')
-rw-r--r--dev-python/jaraco-collections/Manifest1
-rw-r--r--dev-python/jaraco-collections/jaraco-collections-3.7.0.ebuild32
2 files changed, 33 insertions, 0 deletions
diff --git a/dev-python/jaraco-collections/Manifest b/dev-python/jaraco-collections/Manifest
index 14507b975b67..ddfa00286b31 100644
--- a/dev-python/jaraco-collections/Manifest
+++ b/dev-python/jaraco-collections/Manifest
@@ -1,2 +1,3 @@
DIST jaraco.collections-3.5.2.tar.gz 16038 BLAKE2B 3f7f48f4c65e44aba621dd894a84711473ff42e37be8067e356cd6ca0f8740c667cb282bddad4315ddd7c8922c316c57b40984455f0af4bc8bbf4304a12a6779 SHA512 9567ee44fbc5010cc81ee24de792e53b5a225759b5f7d2e7dd932b0cae38e2035fddb5bd3dee5dc08fea9c61e2bf9087418cd192d81c72760f1e0d95a7b3788c
DIST jaraco.collections-3.6.0.tar.gz 16720 BLAKE2B 283e9570729ded2b33b6fd1ab7a7b1414588a48455fc3a3103e4a3fe3e4eadae0d9e925a2f1e2de6ee8973121e1d01923c4c3ea72c618033f776c2e4b9add558 SHA512 a5cfa42e60d4a63463d159090086f9400f6faeeaedd9cba7d46bdfc9fc328b0056d6f2e428de93bfd59ea4f2bdc5d8b71158c5f1592a62e2ebd8e1ed7471e4ef
+DIST jaraco.collections-3.7.0.tar.gz 16874 BLAKE2B 6505856c1e3bb3fe55d84a5c8804481b2057b738cb37dc613f2dacc9fc19772eec3c9e4c310467ef7fcde09b3aff01b974a2ff8976988fb3802a7c77f35407bb SHA512 6ebf276b662bdd78622c345d64be8b919de8e10e248c78a6107e65a58f4b158ba788685f518d1590028c2bc9a13b1a48c30d5e30f964696a87330dba3b1432d7
diff --git a/dev-python/jaraco-collections/jaraco-collections-3.7.0.ebuild b/dev-python/jaraco-collections/jaraco-collections-3.7.0.ebuild
new file mode 100644
index 000000000000..93d208be4d8a
--- /dev/null
+++ b/dev-python/jaraco-collections/jaraco-collections-3.7.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} pypy3 )
+
+inherit distutils-r1
+
+MY_P=${P/-/.}
+DESCRIPTION="Models and classes to supplement the stdlib collections module"
+HOMEPAGE="
+ https://github.com/jaraco/jaraco.collections/
+ https://pypi.org/project/jaraco.collections/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN/-/.}/${MY_P}.tar.gz"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+RDEPEND="
+ dev-python/jaraco-classes[${PYTHON_USEDEP}]
+ dev-python/jaraco-text[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ >=dev-python/setuptools_scm-1.15.0[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest