summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-01-05 09:28:45 +0100
committerMichał Górny <mgorny@gentoo.org>2023-01-05 09:28:45 +0100
commitdc84419cd60dec463fb43204011b8ffeb109774f (patch)
tree3c47f435d6134903573eccabda58a09857682265 /dev-python/google-api-python-client
parentdev-python/lazy-object-proxy: Bump to 1.9.0 (diff)
downloadgentoo-dc84419cd60dec463fb43204011b8ffeb109774f.tar.gz
gentoo-dc84419cd60dec463fb43204011b8ffeb109774f.tar.bz2
gentoo-dc84419cd60dec463fb43204011b8ffeb109774f.zip
dev-python/google-api-python-client: Bump to 2.71.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/google-api-python-client')
-rw-r--r--dev-python/google-api-python-client/Manifest1
-rw-r--r--dev-python/google-api-python-client/google-api-python-client-2.71.0.ebuild53
2 files changed, 54 insertions, 0 deletions
diff --git a/dev-python/google-api-python-client/Manifest b/dev-python/google-api-python-client/Manifest
index f6d70ed891cc..60334b6af55b 100644
--- a/dev-python/google-api-python-client/Manifest
+++ b/dev-python/google-api-python-client/Manifest
@@ -1,2 +1,3 @@
DIST google-api-python-client-2.68.0.gh.tar.gz 37053945 BLAKE2B 7a73b80737b73198531207d203c2010969a9dbdd5012071944ec86bd6c2c63eb0a86bf2941a4c37544629aeae32b367cc8d9209300c63e8d1be39f32bef1d91f SHA512 9b70ad6f05d28198ee82984e263e770c995143770123a8aaeb605aad880464e951b8849bbed8c7cb511bd7beebed1df965fdd53b2e6a161905a0a2e481d5b68a
DIST google-api-python-client-2.70.0.gh.tar.gz 37420341 BLAKE2B 8bc148c2cfeb1be59d3db8494a8701f6fc06949c57d7cc930aba44ee9ab3cc7f4450ec988c37ef8ccc0cb990bbc1fe75415d6f6b94ad00121e6e458698b5ff2b SHA512 5c1b8b0dbf545da17d9d5f3fc6ddd3c966d72b1034bb37e3acc5199dd39d40421b6608d6622ea539864022d0e19bc4a3123e9d666d2687a60fc7928201967ff1
+DIST google-api-python-client-2.71.0.gh.tar.gz 37887241 BLAKE2B 5b0e8f39a4935f6e64e1846b7457e2fef62f91d8b62debd277dd49fe28242ffa6d1f8bf8962b56860448aa0edd8fe23d102062809995b212b775c760d20b403c SHA512 a13e31226991a77f900e87f72232d6722dc34d3b7a0134fed3039a5439d207ee26a3f9caa8b4cc5319acc864e11f07e080c0cea25ff29ab1a775b49278582c83
diff --git a/dev-python/google-api-python-client/google-api-python-client-2.71.0.ebuild b/dev-python/google-api-python-client/google-api-python-client-2.71.0.ebuild
new file mode 100644
index 000000000000..1b0a5fa95e96
--- /dev/null
+++ b/dev-python/google-api-python-client/google-api-python-client-2.71.0.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Google API Client for Python"
+HOMEPAGE="
+ https://github.com/googleapis/google-api-python-client/
+ https://pypi.org/project/google-api-python-client/
+"
+SRC_URI="
+ https://github.com/googleapis/google-api-python-client/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+
+RDEPEND="
+ >=dev-python/httplib2-0.15[${PYTHON_USEDEP}]
+ <dev-python/httplib2-1[${PYTHON_USEDEP}]
+ >=dev-python/google-api-core-2.3.1[${PYTHON_USEDEP}]
+ >=dev-python/google-auth-1.35.0[${PYTHON_USEDEP}]
+ >=dev-python/google-auth-httplib2-0.1.0[${PYTHON_USEDEP}]
+ >=dev-python/uritemplate-3.0.0[${PYTHON_USEDEP}]
+ <dev-python/uritemplate-5[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/oauth2client[${PYTHON_USEDEP}]
+ dev-python/pandas[${PYTHON_USEDEP}]
+ dev-python/parameterized[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # require Internet access (and credentials)
+ tests/test_discovery.py::DiscoveryErrors::test_credentials_and_credentials_file_mutually_exclusive
+ tests/test_discovery.py::DiscoveryFromDocument::test_api_endpoint_override_from_client_options_mapping_object
+ )
+
+ epytest tests
+}