summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPetr Vaněk <arkamar@atlas.cz>2022-08-14 22:36:58 +0200
committerSam James <sam@gentoo.org>2022-08-14 22:31:43 +0100
commitffa1292e771b440b3ebcdddc71a9df898ba93415 (patch)
tree171ba5654130b5e7163e79772945e4b9655e8422 /dev-python/frozendict
parentdev-lang/ghc: sync 8.10.6 from ::haskell (diff)
downloadgentoo-ffa1292e771b440b3ebcdddc71a9df898ba93415.tar.gz
gentoo-ffa1292e771b440b3ebcdddc71a9df898ba93415.tar.bz2
gentoo-ffa1292e771b440b3ebcdddc71a9df898ba93415.zip
dev-python/frozendict: fix pytest dependencies
Fixes: 89e4ee59e046 ("dev-python/frozendict: fix test phase") Fixes: 880f511ea944 ("dev-python/frozendict: add 2.3.4") Closes: https://bugs.gentoo.org/865163 Signed-off-by: Petr Vaněk <arkamar@atlas.cz> Closes: https://github.com/gentoo/gentoo/pull/26863 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-python/frozendict')
-rw-r--r--dev-python/frozendict/frozendict-2.3.2.ebuild2
-rw-r--r--dev-python/frozendict/frozendict-2.3.4.ebuild2
2 files changed, 4 insertions, 0 deletions
diff --git a/dev-python/frozendict/frozendict-2.3.2.ebuild b/dev-python/frozendict/frozendict-2.3.2.ebuild
index 371501d7202e..0424323d8183 100644
--- a/dev-python/frozendict/frozendict-2.3.2.ebuild
+++ b/dev-python/frozendict/frozendict-2.3.2.ebuild
@@ -21,6 +21,8 @@ LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64 ~ppc64"
+distutils_enable_tests pytest
+
python_test() {
cd "${T}" || die
epytest "${S}/test"
diff --git a/dev-python/frozendict/frozendict-2.3.4.ebuild b/dev-python/frozendict/frozendict-2.3.4.ebuild
index fa692c82ed56..f1e01464495c 100644
--- a/dev-python/frozendict/frozendict-2.3.4.ebuild
+++ b/dev-python/frozendict/frozendict-2.3.4.ebuild
@@ -23,6 +23,8 @@ LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64 ~ppc64"
+distutils_enable_tests pytest
+
python_test() {
cd "${T}" || die
epytest "${S}/test"