summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2024-03-09 17:45:21 +0200
committerArthur Zamarin <arthurzam@gentoo.org>2024-03-09 18:20:34 +0200
commit8ec7161a392b70741e9f20377bf692645f1ff204 (patch)
tree4b31c2d569b32bad35071dbf9d0fa5047110f073 /dev-python/flask-migrate
parentdev-python/noseofyeti: add 2.4.8 (diff)
downloadgentoo-8ec7161a392b70741e9f20377bf692645f1ff204.tar.gz
gentoo-8ec7161a392b70741e9f20377bf692645f1ff204.tar.bz2
gentoo-8ec7161a392b70741e9f20377bf692645f1ff204.zip
dev-python/flask-migrate: add 4.0.6
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python/flask-migrate')
-rw-r--r--dev-python/flask-migrate/Manifest1
-rw-r--r--dev-python/flask-migrate/flask-migrate-4.0.6.ebuild46
2 files changed, 47 insertions, 0 deletions
diff --git a/dev-python/flask-migrate/Manifest b/dev-python/flask-migrate/Manifest
index 893877847e7e..1adad2550ec2 100644
--- a/dev-python/flask-migrate/Manifest
+++ b/dev-python/flask-migrate/Manifest
@@ -1 +1,2 @@
DIST Flask-Migrate-4.0.5.gh.tar.gz 26827 BLAKE2B 4b674856bc1177857b1272740351e953099a22f981faf63714ac07748308c77a599ce942e273858df2b0e010a4b962e8c8c9488c3bb750f5c4e9037e4a0c58bf SHA512 cdc02e3f567119604e56e9cafed3e7b40e7335d4c3f42cffb26515a4cec12ff34c16f8d5ae036d841cf846985973980d820cdc5d87a99ebf634b3b17becaeb69
+DIST Flask-Migrate-4.0.6.gh.tar.gz 27087 BLAKE2B 73d96ec3b6483f5ecf181589263f87d2bf4f4c6f430cc7668481ce71ea1674d2a659ff48980034d4416a8891c7eaba1bab02f7eae7821ae22f31146c92b6eb61 SHA512 908668fc16a0f5dfef7a6de61b68ec350ec90c97d181f037be8906c1aa0e67464324bacd2e367462a1adc6b202eb08a203451653fca57a7d26c3e7d85676da42
diff --git a/dev-python/flask-migrate/flask-migrate-4.0.6.ebuild b/dev-python/flask-migrate/flask-migrate-4.0.6.ebuild
new file mode 100644
index 000000000000..1ee6db65ab0a
--- /dev/null
+++ b/dev-python/flask-migrate/flask-migrate-4.0.6.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+MY_P="Flask-Migrate-${PV}"
+DESCRIPTION="SQLAlchemy database migrations for Flask applications using Alembic"
+HOMEPAGE="
+ https://github.com/miguelgrinberg/Flask-Migrate/
+ https://pypi.org/project/Flask-Migrate/
+"
+SRC_URI="
+ https://github.com/miguelgrinberg/Flask-Migrate/archive/v${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+RDEPEND="
+ >=dev-python/alembic-1.9.0[${PYTHON_USEDEP}]
+ >=dev-python/flask-0.9[${PYTHON_USEDEP}]
+ >=dev-python/flask-sqlalchemy-1.0[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests unittest
+
+python_test() {
+ local -x PATH=${T}/bin:${PATH}
+
+ mkdir -p "${T}"/bin || die
+ cat > "${T}"/bin/flask <<-EOF || die
+ #!/bin/sh
+ exec ${EPYTHON} -m flask "\${@}"
+ EOF
+ chmod +x "${T}"/bin/flask || die
+
+ eunittest
+}