summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-05-18 05:03:11 +0200
committerMichał Górny <mgorny@gentoo.org>2023-05-18 05:14:51 +0200
commit7757668fcea35ebe7b7e54ca6136ed0bcc5438ac (patch)
tree1a566e836318dcd30883848e27e7c6a0dbca1f74 /dev-python/etuples
parentdev-python/keystoneauth1: Bump to 5.2.0 (diff)
downloadgentoo-7757668fcea35ebe7b7e54ca6136ed0bcc5438ac.tar.gz
gentoo-7757668fcea35ebe7b7e54ca6136ed0bcc5438ac.tar.bz2
gentoo-7757668fcea35ebe7b7e54ca6136ed0bcc5438ac.zip
dev-python/etuples: Bump to 0.3.9
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/etuples')
-rw-r--r--dev-python/etuples/Manifest1
-rw-r--r--dev-python/etuples/etuples-0.3.9.ebuild31
2 files changed, 32 insertions, 0 deletions
diff --git a/dev-python/etuples/Manifest b/dev-python/etuples/Manifest
index 73ec9aab974a..4b03898ddc32 100644
--- a/dev-python/etuples/Manifest
+++ b/dev-python/etuples/Manifest
@@ -1 +1,2 @@
DIST etuples-0.3.8.gh.tar.gz 45301 BLAKE2B 56fdae84b180b9ab5a81533d4028d8271e443146a4ed456252ca15400a2afb9987c741c5e5155b9ed48eb12bcc6038e081913c49e00b4eaf67a69c52b2a981c5 SHA512 0971baa9c3038ce1bf9974b750f9e642ecaad92c59b12bc69a2beb6cf4b042302580d96d0feae80a280634f56371f681fc1efcf48741a7cd65b35d9a77b66930
+DIST etuples-0.3.9.gh.tar.gz 45310 BLAKE2B e639fd4a1a4d9a1b34b32ab2884bfe933a079d721bb8b16b225d62f63e61e5cd1f1aa0f4113769744dd2ab80e537d73efdc3bcce3d1781089746997c11f3d820 SHA512 d66fac192fe14153b3496e6baa5ee3a0ff2813c26bbf0c3293049a0a50a26f32e14b031877f36e336035bf74853e981b6f75410e1f84b4ebcc84b55331d313e0
diff --git a/dev-python/etuples/etuples-0.3.9.ebuild b/dev-python/etuples/etuples-0.3.9.ebuild
new file mode 100644
index 000000000000..34cfd675c882
--- /dev/null
+++ b/dev-python/etuples/etuples-0.3.9.ebuild
@@ -0,0 +1,31 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python S-expression emulation using tuple-like objects"
+HOMEPAGE="
+ https://pypi.org/project/etuples/
+ https://github.com/pythological/etuples/
+"
+# tests not in sdist, as of 0.3.9
+SRC_URI="
+ https://github.com/pythological/etuples/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~riscv ~x86"
+
+RDEPEND="
+ dev-python/cons[${PYTHON_USEDEP}]
+ dev-python/multipledispatch[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest