summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-06-20 18:47:28 +0200
committerMichał Górny <mgorny@gentoo.org>2024-06-20 19:14:20 +0200
commit4e3a8f42504d684be40cd8a92f856b6255d1a41a (patch)
tree93325e31bfdf90d6edc06e123ad2be78ede17181 /dev-python/djangorestframework
parentdev-python/django-redis: Enable py3.13 (diff)
downloadgentoo-4e3a8f42504d684be40cd8a92f856b6255d1a41a.tar.gz
gentoo-4e3a8f42504d684be40cd8a92f856b6255d1a41a.tar.bz2
gentoo-4e3a8f42504d684be40cd8a92f856b6255d1a41a.zip
dev-python/djangorestframework: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/djangorestframework')
-rw-r--r--dev-python/djangorestframework/Manifest1
-rw-r--r--dev-python/djangorestframework/djangorestframework-3.15.1.ebuild53
2 files changed, 0 insertions, 54 deletions
diff --git a/dev-python/djangorestframework/Manifest b/dev-python/djangorestframework/Manifest
index 473e112edc36..de29aefe1b97 100644
--- a/dev-python/djangorestframework/Manifest
+++ b/dev-python/djangorestframework/Manifest
@@ -1,2 +1 @@
-DIST django-rest-framework-3.15.1.gh.tar.gz 9291840 BLAKE2B daf672a1fb01494f08dd54af7369bd464d4fc1e22ff3c90c0fe787408d4f327710c5e6394e33546a4df2da752dbd774980f092108f2f4e395795af3aead18f89 SHA512 e44c3d861973928194035364fb6b5ddffbcacab959072b2c549971dd6675b5a5f1be13b55856154dbffaefb48dcbd4a63fd9ffbce5456507b52fd5e4648706b9
DIST django-rest-framework-3.15.2.gh.tar.gz 9290406 BLAKE2B 588aebbdd89f749bacd4244707f6b4b0e2a6aef0759973e5451ebcc4acb4d2e1c2d9773ab576e33442f5123ce860cae087622a26d1d208edc70df04057c4d401 SHA512 a24322fb09398ee1608900ae623d8ba44c3cb066fc7921e38f847a93513d3ca549d933da6cfc045a556edfe50dae3431b6782d0241a9f53ac3dbc0caf48fa520
diff --git a/dev-python/djangorestframework/djangorestframework-3.15.1.ebuild b/dev-python/djangorestframework/djangorestframework-3.15.1.ebuild
deleted file mode 100644
index 4bcf2d5c27de..000000000000
--- a/dev-python/djangorestframework/djangorestframework-3.15.1.ebuild
+++ /dev/null
@@ -1,53 +0,0 @@
-# Copyright 1999-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{10..12} )
-
-inherit distutils-r1
-
-MY_P=django-rest-framework-${PV}
-DESCRIPTION="Web APIs with django made easy"
-HOMEPAGE="
- https://www.django-rest-framework.org/
- https://github.com/encode/django-rest-framework/
- https://pypi.org/project/djangorestframework/
-"
-SRC_URI="
- https://github.com/encode/django-rest-framework/archive/${PV}.tar.gz
- -> ${MY_P}.gh.tar.gz
-"
-S=${WORKDIR}/${MY_P}
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~arm64 ~x86"
-
-RDEPEND="
- >=dev-python/django-3.0[${PYTHON_USEDEP}]
- dev-python/pytz[${PYTHON_USEDEP}]
-"
-BDEPEND="
- test? (
- dev-python/inflection[${PYTHON_USEDEP}]
- dev-python/pytest-django[${PYTHON_USEDEP}]
- dev-python/pyyaml[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-
-EPYTEST_DESELECT=(
- tests/test_description.py::TestViewNamesAndDescriptions::test_markdown
-
- # require coreapi (but not skipped properly)
- tests/schemas/test_managementcommand.py::GenerateSchemaTests::test_coreapi_renders_default_schema_with_custom_title_url_and_desc
- tests/schemas/test_managementcommand.py::GenerateSchemaTests::test_coreapi_renders_openapi_json_schema
- tests/schemas/test_managementcommand.py::GenerateSchemaTests::test_renders_corejson_schema
-
- # upstream is removing pytz, apparently it's not tested anymore
- # https://github.com/encode/django-rest-framework/discussions/9342
- tests/test_fields.py::TestPytzNaiveDayLightSavingTimeTimeZoneDateTimeField::test_invalid_inputs
-)