summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-09-08 21:53:31 +0200
committerMichał Górny <mgorny@gentoo.org>2021-09-08 22:26:42 +0200
commit1e7019ca9e7d234036f151f4cbad23be229d9e7b (patch)
tree308c1d9088ca208286a89ddc40becba7ba313e6a /dev-python/django-mptt/django-mptt-0.13.3.ebuild
parentdev-python/google-api-python-client: Bump to 2.20.0 (diff)
downloadgentoo-1e7019ca9e7d234036f151f4cbad23be229d9e7b.tar.gz
gentoo-1e7019ca9e7d234036f151f4cbad23be229d9e7b.tar.bz2
gentoo-1e7019ca9e7d234036f151f4cbad23be229d9e7b.zip
dev-python/django-mptt: Bump to 0.13.3
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/django-mptt/django-mptt-0.13.3.ebuild')
-rw-r--r--dev-python/django-mptt/django-mptt-0.13.3.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-python/django-mptt/django-mptt-0.13.3.ebuild b/dev-python/django-mptt/django-mptt-0.13.3.ebuild
new file mode 100644
index 000000000000..10262c58b326
--- /dev/null
+++ b/dev-python/django-mptt/django-mptt-0.13.3.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..9} )
+inherit distutils-r1
+
+DESCRIPTION="utilities for modified preorder tree traversal and trees of model instances"
+HOMEPAGE="https://github.com/django-mptt/django-mptt"
+SRC_URI="
+ https://github.com/django-mptt/django-mptt/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ >=dev-python/django-1.11[${PYTHON_USEDEP}]
+ dev-python/django-js-asset[${PYTHON_USEDEP}]
+"
+
+python_test() {
+ "${EPYTHON}" tests/manage.py test -v2 myapp ||
+ die "Tests failed with ${EPYTHON}"
+}