summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-12-12 15:43:46 +0100
committerMichał Górny <mgorny@gentoo.org>2022-12-12 16:33:16 +0100
commit413c79912d9653738f5dd4b98e437684f3637b0a (patch)
treeb6e1d7cce03526615f210150c9d705e68294619c /dev-python/django-cache-url
parentdev-python/pycares: Bump to 4.3.0 (diff)
downloadgentoo-413c79912d9653738f5dd4b98e437684f3637b0a.tar.gz
gentoo-413c79912d9653738f5dd4b98e437684f3637b0a.tar.bz2
gentoo-413c79912d9653738f5dd4b98e437684f3637b0a.zip
dev-python/django-cache-url: Bump to 3.4.4
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/django-cache-url')
-rw-r--r--dev-python/django-cache-url/Manifest1
-rw-r--r--dev-python/django-cache-url/django-cache-url-3.4.4.ebuild36
2 files changed, 37 insertions, 0 deletions
diff --git a/dev-python/django-cache-url/Manifest b/dev-python/django-cache-url/Manifest
index 47957238fbbf..9e540ce15552 100644
--- a/dev-python/django-cache-url/Manifest
+++ b/dev-python/django-cache-url/Manifest
@@ -1 +1,2 @@
DIST django-cache-url-3.4.2.gh.tar.gz 8664 BLAKE2B f97bfed1b4be0919d79304242baf7af0c092b440a1888f05c781e70cb4674a83c4f18077c1b3c9ce7dc99223ebe13527e5575af0993446d273cc387ed0e2d8d5 SHA512 7b12ff97c399cd52eef1465a504bf8edd7d422a76af5ead0157a3b52615501b7f152bf58f693255a3ccb81880123ec0efd2ec3590e07f38378e5e812c2ef3799
+DIST django-cache-url-3.4.4.gh.tar.gz 8671 BLAKE2B 5245e87b786470e45ca1e30a39337904577889b15d644fbef94f55e861de7d2bb8b6725b6e62c58424511fb3f81093a6d3107cc1a8f8dc575e5463d6ab2e6c13 SHA512 745fddec8546c4ad4b70d7a039e0954f1c99cb91766a10185b29804cd69560a3dd64f90a85bb1a9ae029d34038944b288b4c497ad15492791121ea9c61fd6ae5
diff --git a/dev-python/django-cache-url/django-cache-url-3.4.4.ebuild b/dev-python/django-cache-url/django-cache-url-3.4.4.ebuild
new file mode 100644
index 000000000000..7037d9f6eefa
--- /dev/null
+++ b/dev-python/django-cache-url/django-cache-url-3.4.4.ebuild
@@ -0,0 +1,36 @@
+# Copyright 2021-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Use Cache URLs in your Django application"
+HOMEPAGE="
+ https://github.com/epicserve/django-cache-url/
+ https://pypi.org/project/django-cache-url/
+"
+SRC_URI="
+ https://github.com/epicserve/django-cache-url/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+RDEPEND="
+ dev-python/django[${PYTHON_USEDEP}]
+"
+
+DOCS=( AUTHORS.rst CHANGELOG.rst README.rst )
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ sed -e '/--cov/d' -i setup.cfg || die
+ distutils-r1_python_prepare_all
+}