summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-02-05 18:15:07 +0200
committerArthur Zamarin <arthurzam@gentoo.org>2022-02-05 18:50:37 +0200
commit82a20a3c7a2ea72b4956108c462f7a40e639faba (patch)
tree28e1f6255a4e87f2b4e3f7f551420ff22375a670 /dev-python/discogs-client
parentdev-python/polygon: add github upstream metadata (diff)
downloadgentoo-82a20a3c7a2ea72b4956108c462f7a40e639faba.tar.gz
gentoo-82a20a3c7a2ea72b4956108c462f7a40e639faba.tar.bz2
gentoo-82a20a3c7a2ea72b4956108c462f7a40e639faba.zip
dev-python/discogs-client: add 2.3.13, ebuild cleanup
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python/discogs-client')
-rw-r--r--dev-python/discogs-client/Manifest1
-rw-r--r--dev-python/discogs-client/discogs-client-2.3.13.ebuild32
2 files changed, 33 insertions, 0 deletions
diff --git a/dev-python/discogs-client/Manifest b/dev-python/discogs-client/Manifest
index 5c531fa574a4..5cf9a0747066 100644
--- a/dev-python/discogs-client/Manifest
+++ b/dev-python/discogs-client/Manifest
@@ -1 +1,2 @@
DIST discogs-client-2.3.12.tar.gz 32604 BLAKE2B 6c7960263d0158fc796edd76f6ccc549d582cbd96666cbf3ae10a3215eee6464c857e1b46c8e76ad2a48308ae9353c347a421189b3c754bd23a0f2ec455d9cfa SHA512 c14ea953e92f2d77909a7af8f840ee5a1df2416e16f6de0b7f0e988f6ef56a07fc04c75b247508dc0d1b5f7033faf6cce80196b610d1169a23350d3e816e2925
+DIST python3-discogs-client-2.3.13.tar.gz 34228 BLAKE2B 621e181bc07c48ca387638fd49bf1b92fc06e1f3b57428a13bdf93c634ceadb8c128dc9c48bebed4d2ef774d301ab70d43935efa903365a1df5ccb6991b689b3 SHA512 7fd3f98c1374173c54d3f4731fcb093548b85ca7c0d5d3396e40733e64306eb29e14b5de0d30269ad92cb0a0b8bbbfeb8b739454e251638472b8c7ffaff4d27e
diff --git a/dev-python/discogs-client/discogs-client-2.3.13.ebuild b/dev-python/discogs-client/discogs-client-2.3.13.ebuild
new file mode 100644
index 000000000000..2ca0f4090ab6
--- /dev/null
+++ b/dev-python/discogs-client/discogs-client-2.3.13.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+if [[ ${PV} == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/joalla/discogs_client.git"
+ inherit git-r3
+else
+ SRC_URI="mirror://pypi/p/python3-${PN}/python3-${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+ S="${WORKDIR}/python3-${P}"
+fi
+
+DESCRIPTION="Continuation of the official Python API client for Discogs"
+HOMEPAGE="https://github.com/joalla/discogs_client
+ https://pypi.org/project/python3-discogs-client/"
+
+LICENSE="BSD-2"
+SLOT="0"
+
+RDEPEND="
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/oauthlib[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests unittest