summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-03-09 06:19:24 +0100
committerMichał Górny <mgorny@gentoo.org>2023-03-09 06:58:52 +0100
commit2b7eb23cccbc8501fcbf0962abe214f7c0d32f60 (patch)
tree63592e81fd68f64c837a9f40d0bcd6e19a730d8d /dev-python/bottleneck
parentdev-python/pydantic: Bump to 1.10.6 (diff)
downloadgentoo-2b7eb23cccbc8501fcbf0962abe214f7c0d32f60.tar.gz
gentoo-2b7eb23cccbc8501fcbf0962abe214f7c0d32f60.tar.bz2
gentoo-2b7eb23cccbc8501fcbf0962abe214f7c0d32f60.zip
dev-python/bottleneck: Bump to 1.3.7
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/bottleneck')
-rw-r--r--dev-python/bottleneck/Manifest1
-rw-r--r--dev-python/bottleneck/bottleneck-1.3.7.ebuild44
2 files changed, 45 insertions, 0 deletions
diff --git a/dev-python/bottleneck/Manifest b/dev-python/bottleneck/Manifest
index 37713fd30792..e3300ba98d10 100644
--- a/dev-python/bottleneck/Manifest
+++ b/dev-python/bottleneck/Manifest
@@ -1 +1,2 @@
+DIST Bottleneck-1.3.7.tar.gz 103067 BLAKE2B d260263fc05b6806203c09555157926f288c60ebb88105b9ad73191c220be0e08370d7a96cb829ec8dd9ac0c2d243aeca62eb1a871e39fe8c85ba6ab507849ac SHA512 ffeacb13e5a99db85e1580b9f2ead98239b4fd0b253a3c242a5507a026b439b9927ea49becec7e4d2d8f8e4ced15f43514c0af99379389db141ae50c4513e011
DIST bottleneck-1.3.6.gh.tar.gz 119180 BLAKE2B 8ba4ccb260731b1583eb62249fa0bdf8d25b96c978f5ff91003aaf965b0f5f5d000fb2a049f70e86266ebeb6e748cadd8e7d0ccafad1ed1a50f6aba18452c97a SHA512 0c0af2ee5ca77f86f855800748a4ce4c0fe85f9da445aeeaaffabdcdc0e2c47b18c5590b208cb8aed52d4ec4a1aa9c023588d11d1c5aa581e2c00d3d4c1ba73c
diff --git a/dev-python/bottleneck/bottleneck-1.3.7.ebuild b/dev-python/bottleneck/bottleneck-1.3.7.ebuild
new file mode 100644
index 000000000000..d3008c73bce6
--- /dev/null
+++ b/dev-python/bottleneck/bottleneck-1.3.7.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Fast NumPy array functions written in C"
+HOMEPAGE="
+ https://github.com/pydata/bottleneck/
+ https://pypi.org/project/Bottleneck/
+"
+SRC_URI="
+ $(pypi_sdist_url --no-normalize Bottleneck)
+"
+S=${WORKDIR}/${P^}
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ >=dev-python/numpy-1.9.1[${PYTHON_USEDEP}]
+"
+DEPEND="
+ ${RDEPEND}
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ # don't overwrites user's optimization level
+ sed -e '/extra_compile_args=\["-O2"\]/d' -i setup.py || die
+
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ rm -rf bottleneck || die
+ epytest --pyargs bottleneck
+}