summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-08-17 06:08:17 +0200
committerMichał Górny <mgorny@gentoo.org>2024-08-17 06:08:17 +0200
commitd05fdcbf8ff848965aa64d9d6dc99e831614f35b (patch)
treedfd18f6c6e36ddef494f94a4e663e567bcc8d119 /dev-python/botocore
parentdev-util/gitlab-runner: drop 17.0.1, 17.1.0 (diff)
downloadgentoo-d05fdcbf8ff848965aa64d9d6dc99e831614f35b.tar.gz
gentoo-d05fdcbf8ff848965aa64d9d6dc99e831614f35b.tar.bz2
gentoo-d05fdcbf8ff848965aa64d9d6dc99e831614f35b.zip
dev-python/botocore: Bump to 1.35.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/botocore')
-rw-r--r--dev-python/botocore/Manifest1
-rw-r--r--dev-python/botocore/botocore-1.35.0.ebuild76
2 files changed, 77 insertions, 0 deletions
diff --git a/dev-python/botocore/Manifest b/dev-python/botocore/Manifest
index fb7411cd2e8b..00f141e0eaf8 100644
--- a/dev-python/botocore/Manifest
+++ b/dev-python/botocore/Manifest
@@ -5,3 +5,4 @@ DIST botocore-1.34.159.gh.tar.gz 13286596 BLAKE2B 76548a1a0dacbaeadb4cc95cdbb50f
DIST botocore-1.34.160.gh.tar.gz 13290395 BLAKE2B 609ade4e363b1c65409457e187c09e8eea633ab7d482bae5be3580093ca404ae82363e9785d07b65dee3504c63e5c4dc6521717a6698c97f7a404f58103c8e8f SHA512 655348a9e7f88ad0abaab3d0b4bb380ca16c705a1035eedecf44e8b546583720f0f6d01136b0d333e5828069c4d45c7f27530ba4b7f8c3ee684bd4cd0e233ce4
DIST botocore-1.34.161.gh.tar.gz 13290428 BLAKE2B 9a12df5e533560039d69225ef04345765cdefa11546210a2ad791d38532a54536a0c8705c29c1293b31fec7589f0512fa6f01570342d6f1fbba9a3278c06700f SHA512 8c59cadaa2cedefaeb11057f344c1488c879629199f6e5038c49668cbc814ac1ab68031893c401a5f8baecaea333929822997e81e4f644ebfb09a3af85b7a189
DIST botocore-1.34.162.gh.tar.gz 13292394 BLAKE2B 4456beb1f4cafe67d5a48ea3ae972d369d89c47a5b9b534f78d3977fe5a6f199a44130f54619d133d2b872b7260319398b8c37e0a262412b8dcbb1ac4daac718 SHA512 0002227f03545b6aaffd920b5e5f70ade96c13faf9adb185e76684cb25465a93ca89711d046f435e164e5c377e4c9fbb7155d4b1037875e03cfc4fe6508e034c
+DIST botocore-1.35.0.gh.tar.gz 13294975 BLAKE2B a0cbafd1b0da5cd7150ea7a2e21b1209b206b7afcb86ad3ff004ca1c96f47da34eff29a43568f0e9a2dca3443516fdb6adf7bd3778835b908fa5fb3a8d22f79a SHA512 7d0c9815703ef49a8958ed1a5159018320108ae86efe20e6dff182db24ceeb67968db7027ee75809a1ebd1c835709d0d758b0699742bca2e435888dbe5e15a97
diff --git a/dev-python/botocore/botocore-1.35.0.ebuild b/dev-python/botocore/botocore-1.35.0.ebuild
new file mode 100644
index 000000000000..4f1ad852bdc1
--- /dev/null
+++ b/dev-python/botocore/botocore-1.35.0.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit distutils-r1
+
+DESCRIPTION="Low-level, data-driven core of boto 3"
+HOMEPAGE="
+ https://github.com/boto/botocore/
+ https://pypi.org/project/botocore/
+"
+SRC_URI="
+ https://github.com/boto/botocore/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ <dev-python/jmespath-2[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ >=dev-python/urllib3-1.25.4[${PYTHON_USEDEP}]
+"
+# unbundled packages
+RDEPEND+="
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/jsonschema[${PYTHON_USEDEP}]
+ )
+"
+
+EPYTEST_XDIST=1
+distutils_enable_tests pytest
+
+src_prepare() {
+ # unpin deps
+ sed -i -e "s:>=.*':':" setup.py || die
+
+ # unbundle deps
+ rm -r botocore/vendored || die
+ find -name '*.py' -exec sed -i \
+ -e 's:from botocore[.]vendored import:import:' \
+ -e 's:from botocore[.]vendored[.]:from :' \
+ {} + || die
+
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # rely on bundled six
+ tests/functional/test_six_imports.py::test_no_bare_six_imports
+ tests/functional/test_six_threading.py::test_six_thread_safety
+ )
+
+ case ${EPYTHON} in
+ python3.13)
+ EPYTEST_DESELECT+=(
+ # memory use tests, probably fragile
+ tests/functional/leak/test_resource_leaks.py::TestDoesNotLeakMemory
+ )
+ ;;
+ esac
+
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest tests/{functional,unit}
+}