summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-08-15 04:56:01 +0200
committerMichał Górny <mgorny@gentoo.org>2024-08-15 05:47:43 +0200
commit0dd19893c4f9d5778ec9bfe950a86a1dc2741b3b (patch)
treef8f98a937f98d969c91292c732c3c1fca32fb258 /dev-python/botocore
parentapp-containers/cri-o: add 1.30.4 (diff)
downloadgentoo-0dd19893c4f9d5778ec9bfe950a86a1dc2741b3b.tar.gz
gentoo-0dd19893c4f9d5778ec9bfe950a86a1dc2741b3b.tar.bz2
gentoo-0dd19893c4f9d5778ec9bfe950a86a1dc2741b3b.zip
dev-python/botocore: Bump to 1.34.161
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/botocore')
-rw-r--r--dev-python/botocore/Manifest1
-rw-r--r--dev-python/botocore/botocore-1.34.161.ebuild76
2 files changed, 77 insertions, 0 deletions
diff --git a/dev-python/botocore/Manifest b/dev-python/botocore/Manifest
index 81e057547871..c5a986fdec8e 100644
--- a/dev-python/botocore/Manifest
+++ b/dev-python/botocore/Manifest
@@ -3,3 +3,4 @@ DIST botocore-1.34.153.gh.tar.gz 13269606 BLAKE2B 1b2ec1af3b699c18c5761fe72b8488
DIST botocore-1.34.158.gh.tar.gz 13282704 BLAKE2B c244a36093cdaf57ac82dc11a3e9d4268d7cce36b8119674530228825f6ec4053abbc909dd664a1ea10ec48e0c418b90803275aabc89a41a99eaba6e138a5a17 SHA512 b60c743bfd1a1f3806c6ae71158a998587b8e87f43bdbe88c960cee19bcef41a4b3fd2fe5f50408abc97b22200a689990f79cbb6e952347c747e4bc8c21ae368
DIST botocore-1.34.159.gh.tar.gz 13286596 BLAKE2B 76548a1a0dacbaeadb4cc95cdbb50f22bc8b61e8b9645caf1d36cde94fed824d0bcc7349626e33792593bcf715e4dd3978f2dc4d4dfeaf8a1bfcb428f99ee8a1 SHA512 1687ab7897dbe68189e812193c9c2134753c0bdd72af109516a2a3bcdda53c16edbb0e76b8f6cd7df0fd29e16de33f78135a3c560444b6d9c5291b3e558c2a03
DIST botocore-1.34.160.gh.tar.gz 13290395 BLAKE2B 609ade4e363b1c65409457e187c09e8eea633ab7d482bae5be3580093ca404ae82363e9785d07b65dee3504c63e5c4dc6521717a6698c97f7a404f58103c8e8f SHA512 655348a9e7f88ad0abaab3d0b4bb380ca16c705a1035eedecf44e8b546583720f0f6d01136b0d333e5828069c4d45c7f27530ba4b7f8c3ee684bd4cd0e233ce4
+DIST botocore-1.34.161.gh.tar.gz 13290428 BLAKE2B 9a12df5e533560039d69225ef04345765cdefa11546210a2ad791d38532a54536a0c8705c29c1293b31fec7589f0512fa6f01570342d6f1fbba9a3278c06700f SHA512 8c59cadaa2cedefaeb11057f344c1488c879629199f6e5038c49668cbc814ac1ab68031893c401a5f8baecaea333929822997e81e4f644ebfb09a3af85b7a189
diff --git a/dev-python/botocore/botocore-1.34.161.ebuild b/dev-python/botocore/botocore-1.34.161.ebuild
new file mode 100644
index 000000000000..4f1ad852bdc1
--- /dev/null
+++ b/dev-python/botocore/botocore-1.34.161.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit distutils-r1
+
+DESCRIPTION="Low-level, data-driven core of boto 3"
+HOMEPAGE="
+ https://github.com/boto/botocore/
+ https://pypi.org/project/botocore/
+"
+SRC_URI="
+ https://github.com/boto/botocore/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ <dev-python/jmespath-2[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ >=dev-python/urllib3-1.25.4[${PYTHON_USEDEP}]
+"
+# unbundled packages
+RDEPEND+="
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/jsonschema[${PYTHON_USEDEP}]
+ )
+"
+
+EPYTEST_XDIST=1
+distutils_enable_tests pytest
+
+src_prepare() {
+ # unpin deps
+ sed -i -e "s:>=.*':':" setup.py || die
+
+ # unbundle deps
+ rm -r botocore/vendored || die
+ find -name '*.py' -exec sed -i \
+ -e 's:from botocore[.]vendored import:import:' \
+ -e 's:from botocore[.]vendored[.]:from :' \
+ {} + || die
+
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # rely on bundled six
+ tests/functional/test_six_imports.py::test_no_bare_six_imports
+ tests/functional/test_six_threading.py::test_six_thread_safety
+ )
+
+ case ${EPYTHON} in
+ python3.13)
+ EPYTEST_DESELECT+=(
+ # memory use tests, probably fragile
+ tests/functional/leak/test_resource_leaks.py::TestDoesNotLeakMemory
+ )
+ ;;
+ esac
+
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest tests/{functional,unit}
+}