summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-07-09 20:47:52 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2022-07-09 20:48:23 +0300
commita52ad17a403ad738bea45fc3aa294c519e906685 (patch)
tree7f799357fb8b9fba26188d003d058bb8c94c3cea /dev-python/bibtexparser
parentdev-python/hypothesis: add 6.50.1 (diff)
downloadgentoo-a52ad17a403ad738bea45fc3aa294c519e906685.tar.gz
gentoo-a52ad17a403ad738bea45fc3aa294c519e906685.tar.bz2
gentoo-a52ad17a403ad738bea45fc3aa294c519e906685.zip
dev-python/bibtexparser: add 1.3.0
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python/bibtexparser')
-rw-r--r--dev-python/bibtexparser/Manifest1
-rw-r--r--dev-python/bibtexparser/bibtexparser-1.3.0.ebuild30
2 files changed, 31 insertions, 0 deletions
diff --git a/dev-python/bibtexparser/Manifest b/dev-python/bibtexparser/Manifest
index bc1d3530d62a..0367f3042790 100644
--- a/dev-python/bibtexparser/Manifest
+++ b/dev-python/bibtexparser/Manifest
@@ -1 +1,2 @@
DIST bibtexparser-1.2.0.gh.tar.gz 88600 BLAKE2B f02fca0330f035b3d9051c04ab5da57232178c637d250839c3939780424d2be9afa619d7a7781cbc92917da12aeb5f35847a54f460823b46a2a717f4b0ca6f8e SHA512 c8775f17d963c6dc5cf3f9dda52c798b70c939cf4c7a90501194561abd7f2386d6681cc236615366a9d8917ad01238fc2e6a4299f98b50b594c74c99bdb3ecee
+DIST bibtexparser-1.3.0.gh.tar.gz 90408 BLAKE2B 64460dfeea6d2ab53faba99bc0dab261e63f63fed8a4bbcf87a6fd2f4e11c35f8f3606f0bbc4d9ab99f70a1e1d6bd1f85440f730fe787a7aadd36f79c004034f SHA512 0a62d3181e2f5c1eb097f1799b871749de4ae73f09d06e40937909f2aa53d1d1e3bc1b1061e14caa048a4fb95e69ae989c94427952d759336686606831c7ca09
diff --git a/dev-python/bibtexparser/bibtexparser-1.3.0.ebuild b/dev-python/bibtexparser/bibtexparser-1.3.0.ebuild
new file mode 100644
index 000000000000..107c6d6df9f2
--- /dev/null
+++ b/dev-python/bibtexparser/bibtexparser-1.3.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="A BibTeX parser written in Python"
+HOMEPAGE="
+ https://github.com/sciunto-org/python-bibtexparser/
+ https://pypi.org/project/bibtexparser/
+"
+SRC_URI="
+ https://github.com/sciunto-org/python-bibtexparser/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+S="${WORKDIR}/python-${P}"
+
+LICENSE="|| ( BSD LGPL-3 )"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-python/pyparsing[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest