summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-05-15 09:19:27 +0200
committerMichał Górny <mgorny@gentoo.org>2021-05-15 10:34:09 +0200
commit403507a0474b0145690cc8700225673a09a178d2 (patch)
treecceec1399626bac34707deabec502587c95f8221 /dev-python/aiodns
parentdev-python/pytest-cov: Bump to 2.12.0 (diff)
downloadgentoo-403507a0474b0145690cc8700225673a09a178d2.tar.gz
gentoo-403507a0474b0145690cc8700225673a09a178d2.tar.bz2
gentoo-403507a0474b0145690cc8700225673a09a178d2.zip
dev-python/aiodns: Bump to 3.0.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/aiodns')
-rw-r--r--dev-python/aiodns/Manifest1
-rw-r--r--dev-python/aiodns/aiodns-3.0.0.ebuild25
2 files changed, 26 insertions, 0 deletions
diff --git a/dev-python/aiodns/Manifest b/dev-python/aiodns/Manifest
index e13432e4f1a8..9f41ab2f6a22 100644
--- a/dev-python/aiodns/Manifest
+++ b/dev-python/aiodns/Manifest
@@ -1 +1,2 @@
DIST aiodns-2.0.0.tar.gz 5948 BLAKE2B 70944ffbfa3fa1c591c5aab6ce2c4c59564a7665fd2eda1b544616a4481e58464f918081dfb21f74db08ebe4c7e43eebd17e0dc314cf79423835a182a257cd11 SHA512 d80b8f7641234c4d367e4554b10c5a66265e75ee82c58adf2a36f9e369bb1dbf4341dd6459f10540b771de3f102454511ca81eddf3082733e88c09bbdf125fe0
+DIST aiodns-3.0.0.tar.gz 6743 BLAKE2B 2a3c61156069fa598df58191b35383da3e054396cdeb1bc8916cc0414bb6efc89d45789883a5b4f33e3a08a6ee544356b02d6c697c096deae3398f0ff4d3c316 SHA512 8c1016f3b0cb461e70e9a55034f9ad3b3db705a845bf20bb6503c7a5d592b4c5d2e8ddc60b375c5fafdc559dc4566736f4c93f26710be2dcbd181284ef039825
diff --git a/dev-python/aiodns/aiodns-3.0.0.ebuild b/dev-python/aiodns/aiodns-3.0.0.ebuild
new file mode 100644
index 000000000000..e36811f62233
--- /dev/null
+++ b/dev-python/aiodns/aiodns-3.0.0.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{7..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="Simple DNS resolver for asyncio"
+HOMEPAGE="https://github.com/saghul/aiodns/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE=""
+# Tests fail with network-sandbox, since they try to resolve google.com
+RESTRICT="test"
+
+RDEPEND=">=dev-python/pycares-3[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}"
+
+python_test() {
+ "${EPYTHON}" tests.py -v || die
+}