summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2016-03-04 12:32:28 +0100
committerAlexis Ballier <aballier@gentoo.org>2016-03-04 12:32:34 +0100
commit327eb3d7ca5f396d41c283e867b8f7b198d9ae84 (patch)
treefab5018c285727aa036c3222eb12d14d1d5d8510 /dev-ml/menhir/menhir-20160303.ebuild
parentdev-ml/utop: bump to 1.18.2 (diff)
downloadgentoo-327eb3d7ca5f396d41c283e867b8f7b198d9ae84.tar.gz
gentoo-327eb3d7ca5f396d41c283e867b8f7b198d9ae84.tar.bz2
gentoo-327eb3d7ca5f396d41c283e867b8f7b198d9ae84.zip
dev-ml/menhir: bump to 20160303
Package-Manager: portage-2.2.27 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ml/menhir/menhir-20160303.ebuild')
-rw-r--r--dev-ml/menhir/menhir-20160303.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/dev-ml/menhir/menhir-20160303.ebuild b/dev-ml/menhir/menhir-20160303.ebuild
new file mode 100644
index 000000000000..497e91f36f20
--- /dev/null
+++ b/dev-ml/menhir/menhir-20160303.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit findlib eutils
+
+DESCRIPTION="LR(1) parser generator for the OCaml language"
+HOMEPAGE="http://gallium.inria.fr/~fpottier/menhir/"
+SRC_URI="http://gallium.inria.fr/~fpottier/menhir/${P}.tar.gz"
+
+LICENSE="QPL-1.0 LGPL-2-with-linking-exception"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples +ocamlopt"
+
+RDEPEND=">=dev-lang/ocaml-4.02:=[ocamlopt?]"
+DEPEND="${RDEPEND}
+ dev-ml/ocamlbuild"
+
+src_configure() {
+ if ! use ocamlopt ; then
+ export TARGET=byte
+ fi
+}
+
+src_compile() {
+ emake PREFIX="${EPREFIX}"/usr -j1
+}
+
+src_install() {
+ findlib_src_preinst
+ emake PREFIX="${ED}"/usr docdir="${ED}"/usr/share/doc/"${PF}" $(use examples || echo "DOCS=manual.pdf") install
+ use examples && docompress -x /usr/share/doc/${PF}/demos
+ dodoc AUTHORS CHANGES
+}