summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2023-03-14 21:22:28 +0100
committerConrad Kostecki <conikost@gentoo.org>2023-03-14 21:22:28 +0100
commitdccd8086cd0f7b62fd94a5cb9efafc31b85004a2 (patch)
tree5cd32e4f2b8be7d6b9be9615e534107bc8607f4c /dev-lua
parentkde-plasma/xembed-sni-proxy: drop 5.27.2 (diff)
downloadgentoo-dccd8086cd0f7b62fd94a5cb9efafc31b85004a2.tar.gz
gentoo-dccd8086cd0f7b62fd94a5cb9efafc31b85004a2.tar.bz2
gentoo-dccd8086cd0f7b62fd94a5cb9efafc31b85004a2.zip
dev-lua/luasec: add 1.3.0
Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'dev-lua')
-rw-r--r--dev-lua/luasec/Manifest1
-rw-r--r--dev-lua/luasec/luasec-1.3.0.ebuild89
2 files changed, 90 insertions, 0 deletions
diff --git a/dev-lua/luasec/Manifest b/dev-lua/luasec/Manifest
index f2802314e044..36577684fbd7 100644
--- a/dev-lua/luasec/Manifest
+++ b/dev-lua/luasec/Manifest
@@ -1 +1,2 @@
DIST luasec-1.2.0.tar.gz 53379 BLAKE2B dad93b341565b602fa02a5551a127bce42e76cee5abb0314f9cc4a98f162d23b0f8b4b9c0f16423095e4b54ec5ab260ee06bef5993ad46f559ad1295dcc28856 SHA512 5564f73495bef7c5683285ff7648c7b82a3a3dfdce96e88c77cc8835427b6595a694e5a2bf0a4f6332fe52b8aed3d94531607df81260d7597458a6fb0465d3fe
+DIST luasec-1.3.0.tar.gz 54704 BLAKE2B f16009922f9fcb60f8e1da99011e683ad6e51afa218b936909a2a6ab9814d892e6d11307b3bf562292d0acd4ad2fb8875e4cc53c21d07f43aa056e54a451a205 SHA512 5dcaca773ad6ee00ca33cfcc2060c763a8c75ad45753a4e5f11e6e76bdb2a49a8b46780efec12146f691f900326218e63c11af5abb709ca84c16bb77ce791943
diff --git a/dev-lua/luasec/luasec-1.3.0.ebuild b/dev-lua/luasec/luasec-1.3.0.ebuild
new file mode 100644
index 000000000000..56a3d8392158
--- /dev/null
+++ b/dev-lua/luasec/luasec-1.3.0.ebuild
@@ -0,0 +1,89 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+LUA_COMPAT=( lua5-{1..4} luajit )
+
+inherit lua toolchain-funcs
+
+DESCRIPTION="Lua binding for OpenSSL library to provide TLS/SSL communication"
+HOMEPAGE="https://github.com/brunoos/luasec"
+SRC_URI="https://github.com/brunoos/luasec/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+
+RDEPEND="
+ >=dev-lua/luasocket-3.0_rc1_p20200328-r103[${LUA_USEDEP}]
+ dev-libs/openssl:0=
+ ${LUA_DEPS}
+"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+lua_src_prepare() {
+ pushd "${BUILD_DIR}" || die
+
+ ${ELUA} src/options.lua -g /usr/include/openssl/ssl.h > src/options.c || die
+
+ popd
+}
+
+src_prepare() {
+ default
+
+ # Respect users CFLAGS
+ sed -e 's/-O2//g' -i src/Makefile || die
+
+ # Allow to redefine libraries linking
+ sed -e 's/LIBS=/LIBS?=/g' -i src/Makefile || die
+
+ lua_copy_sources
+
+ lua_foreach_impl lua_src_prepare
+}
+
+lua_src_compile() {
+ pushd "${BUILD_DIR}" || die
+
+ local myemakeargs=(
+ "CC=$(tc-getCC)"
+ "CCLD=$(tc-getCC)"
+ "INC_PATH=-I$(lua_get_include_dir)"
+ "LIB_PATH=-L$(lua_get_cmod_dir)/socket"
+ "LIBS=$($(tc-getPKG_CONFIG) --libs openssl) $(lua_get_cmod_dir)/socket/core.so"
+ "MYLDFLAGS=-Wl,-rpath,$(lua_get_cmod_dir)/socket -Wl,-soname=socket/core.so"
+ "EXTRA="
+ "DEFS="
+ )
+
+ emake "${myemakeargs[@]}" linux
+
+ popd
+}
+
+src_compile() {
+ lua_foreach_impl lua_src_compile
+}
+
+lua_src_install() {
+ pushd "${BUILD_DIR}" || die
+
+ local emakeargs=(
+ "DESTDIR=${ED}"
+ "LUAPATH=$(lua_get_lmod_dir)"
+ "LUACPATH=$(lua_get_cmod_dir)"
+ )
+
+ emake "${emakeargs[@]}" install
+
+ popd
+}
+
+src_install() {
+ lua_foreach_impl lua_src_install
+
+ einstalldocs
+}