summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2019-02-23 15:19:18 +0100
committerThomas Deutschmann <whissi@gentoo.org>2019-02-23 15:19:23 +0100
commit56ed2d8c87eb9117cfd4ddb2c1e7be2dc5a5ea6b (patch)
tree5fe72abc880ea05e9261cdf41b631deebb1181d5 /dev-libs/xapian/xapian-1.2.24.ebuild
parentnet-misc/networkmanager: security bump to 1.14.6 (diff)
downloadgentoo-56ed2d8c87eb9117cfd4ddb2c1e7be2dc5a5ea6b.tar.gz
gentoo-56ed2d8c87eb9117cfd4ddb2c1e7be2dc5a5ea6b.tar.bz2
gentoo-56ed2d8c87eb9117cfd4ddb2c1e7be2dc5a5ea6b.zip
Revert "dev-libs/xapian: remove older versions"
This partially reverts commit c9ef851344067d8b1dd2efa827faefa74f25b6a4. =dev-libs/xapian-1.2.24 is still required for stable dev-perl/Search-Xapian-1.2.25.0. Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
Diffstat (limited to 'dev-libs/xapian/xapian-1.2.24.ebuild')
-rw-r--r--dev-libs/xapian/xapian-1.2.24.ebuild66
1 files changed, 66 insertions, 0 deletions
diff --git a/dev-libs/xapian/xapian-1.2.24.ebuild b/dev-libs/xapian/xapian-1.2.24.ebuild
new file mode 100644
index 000000000000..ebe151278a9c
--- /dev/null
+++ b/dev-libs/xapian/xapian-1.2.24.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="5"
+
+inherit eutils
+
+MY_P="${PN}-core-${PV}"
+
+DESCRIPTION="Xapian Probabilistic Information Retrieval library"
+HOMEPAGE="http://www.xapian.org/"
+SRC_URI="http://oligarchy.co.uk/xapian/${PV}/${MY_P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0/1.2.22" # ABI version of libxapian.so, prefixed with 1.2.
+KEYWORDS="alpha amd64 arm ~arm64 hppa ia64 ~mips ppc ppc64 ~s390 sparc x86"
+IUSE="doc static-libs -cpu_flags_x86_sse +cpu_flags_x86_sse2 +brass +chert +inmemory"
+
+DEPEND="sys-libs/zlib"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${MY_P}"
+
+src_configure() {
+ local myconf=""
+
+ einfo
+ if use cpu_flags_x86_sse2; then
+ einfo "Using sse2"
+ myconf="${myconf} --enable-sse=sse2"
+ else
+ if use cpu_flags_x86_sse; then
+ einfo "Using sse"
+ myconf="${myconf} --enable-sse=sse"
+ else
+ einfo "Disabling sse and sse2"
+ myconf="${myconf} --disable-sse"
+ fi
+ fi
+ einfo
+
+ myconf="${myconf} $(use_enable static-libs static)"
+
+ use brass || myconf="${myconf} --disable-backend-brass"
+ use chert || myconf="${myconf} --disable-backend-chert"
+ use inmemory || myconf="${myconf} --disable-backend-inmemory"
+
+ myconf="${myconf} --enable-backend-flint --enable-backend-remote"
+
+ econf $myconf
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+
+ mv "${ED}usr/share/doc/xapian-core" "${ED}usr/share/doc/${PF}" || die
+ use doc || rm -rf "${ED}usr/share/doc/${PF}"
+
+ dodoc AUTHORS HACKING PLATFORMS README NEWS
+
+ prune_libtool_files --all
+}
+
+src_test() {
+ emake check VALGRIND=
+}