summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2018-03-25 02:42:15 -0400
committerTim Harder <radhermit@gentoo.org>2018-03-25 02:42:15 -0400
commitde6b692ea5a1ae39b2798267ef133c52ef42b8d9 (patch)
tree5f2601e47a9c306d87e7f39f57c658de010a404f /dev-libs/uthash
parentdev-lisp/clisp: keyworded 2.49.90 for ia64, bug #649816 (diff)
downloadgentoo-de6b692ea5a1ae39b2798267ef133c52ef42b8d9.tar.gz
gentoo-de6b692ea5a1ae39b2798267ef133c52ef42b8d9.tar.bz2
gentoo-de6b692ea5a1ae39b2798267ef133c52ef42b8d9.zip
dev-libs/uthash: version bump to 2.0.2
Diffstat (limited to 'dev-libs/uthash')
-rw-r--r--dev-libs/uthash/Manifest1
-rw-r--r--dev-libs/uthash/files/uthash-2.0.2-cflags.patch11
-rw-r--r--dev-libs/uthash/uthash-2.0.2.ebuild30
3 files changed, 42 insertions, 0 deletions
diff --git a/dev-libs/uthash/Manifest b/dev-libs/uthash/Manifest
index 85c03a47cc1b..d4476c4442f2 100644
--- a/dev-libs/uthash/Manifest
+++ b/dev-libs/uthash/Manifest
@@ -1,2 +1,3 @@
DIST uthash-1.9.7.tar.bz2 373059 BLAKE2B 59e24e42a935e44da840ef7a204b43c19bc837b6a5c87ed464143b67608021661603af4f76d143ac5454082f4e391bccc2fd5b443cf23527ca6ef9b530751de0 SHA512 8c02f9ac846a6bfd7292724a3683ae360ff37bba8e3ca98fca106da84976cac9c61766069989ee2c633b20bf82b64658400687a7cfbccab5e98e5fb6cb2e5caa
DIST uthash-1.9.9.tar.gz 225620 BLAKE2B 4c23cc11c54ac2c8af96522455126a5fdfb1f533078f3f8259b33376d9e08ee6a347edc16951a732ab5c1100e302f81b6f7c7477da1ab0d36b794ce5a3400583 SHA512 40b888529db6baba7bdb0a11c3f782719c40470f6b8e4d75ed480c4c465606e990abf65786156a93f4e2f9c8805cbc098550cc3c62e33b7345fa5bf6d146a8c4
+DIST uthash-2.0.2.tar.gz 191173 BLAKE2B a4a2ddb19fcc9af1105bc07deb8ccbe9c3f04518b609f7cfd16f0a05ec3e16ffb25fb5f0a5f258413f9f52facaa26adf4ea0683415416c12ab36bf11883976ae SHA512 0c2e686eb5a1d6a03a6fa1d42e803fca4e9b60b2d965c635a5a33d487c8d115f1f8155ff99a0e1874b69f6b66c04ea7d8866472a39abe5d1a23ae73f6fa956d7
diff --git a/dev-libs/uthash/files/uthash-2.0.2-cflags.patch b/dev-libs/uthash/files/uthash-2.0.2-cflags.patch
new file mode 100644
index 000000000000..e71506bce15b
--- /dev/null
+++ b/dev-libs/uthash/files/uthash-2.0.2-cflags.patch
@@ -0,0 +1,11 @@
+--- uthash-2.0.2/tests/Makefile
++++ uthash-2.0.2/tests/Makefile
+@@ -18,7 +18,7 @@
+ CFLAGS += -I$(HASHDIR)
+ #CFLAGS += -DHASH_BLOOM=16
+ #CFLAGS += -O2
+-CFLAGS += -g
++#CFLAGS += -g
+ #CFLAGS += -Wstrict-aliasing=2
+ CFLAGS += -Wall
+ #CFLAGS += -Wextra
diff --git a/dev-libs/uthash/uthash-2.0.2.ebuild b/dev-libs/uthash/uthash-2.0.2.ebuild
new file mode 100644
index 000000000000..3800e6d66a65
--- /dev/null
+++ b/dev-libs/uthash/uthash-2.0.2.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit toolchain-funcs
+
+DESCRIPTION="An easy-to-use hash implementation for C programmers"
+HOMEPAGE="https://troydhanson.github.io/uthash/index.html"
+SRC_URI="https://github.com/troydhanson/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD-1"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~sparc ~x86"
+IUSE="test"
+
+DEPEND="test? ( dev-lang/perl )"
+RDEPEND=""
+
+PATCHES=( "${FILESDIR}"/${P}-cflags.patch )
+
+src_test() {
+ cd tests || die
+ emake CC="$(tc-getCC)"
+}
+
+src_install() {
+ doheader src/*.h
+ dodoc doc/*.txt
+}