summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-libs/uthash
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-libs/uthash')
-rw-r--r--dev-libs/uthash/Manifest2
-rw-r--r--dev-libs/uthash/metadata.xml15
-rw-r--r--dev-libs/uthash/uthash-1.9.7.ebuild32
-rw-r--r--dev-libs/uthash/uthash-1.9.9.ebuild33
4 files changed, 82 insertions, 0 deletions
diff --git a/dev-libs/uthash/Manifest b/dev-libs/uthash/Manifest
new file mode 100644
index 000000000000..ce0ff431d76e
--- /dev/null
+++ b/dev-libs/uthash/Manifest
@@ -0,0 +1,2 @@
+DIST uthash-1.9.7.tar.bz2 373059 SHA256 956f5c99798349c413275fe4c9ff128d72e280655dadbe4365f8e9fbda91393f SHA512 8c02f9ac846a6bfd7292724a3683ae360ff37bba8e3ca98fca106da84976cac9c61766069989ee2c633b20bf82b64658400687a7cfbccab5e98e5fb6cb2e5caa WHIRLPOOL bd673e371470d0576524a9e8f096beb7b8ae713f5bdca5b513077932e2fc78bc8e08249af8f5b6c0c213ed41775d8e5fc9483b6a330423760864ec5748dba041
+DIST uthash-1.9.9.tar.gz 225620 SHA256 f2f10115f4de03b98d8c2e860e241d165aa15019bd634ee0e3debe58341bbf0c SHA512 40b888529db6baba7bdb0a11c3f782719c40470f6b8e4d75ed480c4c465606e990abf65786156a93f4e2f9c8805cbc098550cc3c62e33b7345fa5bf6d146a8c4 WHIRLPOOL 89be54eb95221d18b1676798cd1a823d625567035f59abc5dcf6b98e7c4343422b5c049395cece8585dce5eb7f99c5fa95bdcb6c5706dd6e67560904a6fffcf4
diff --git a/dev-libs/uthash/metadata.xml b/dev-libs/uthash/metadata.xml
new file mode 100644
index 000000000000..6d39bbae5c45
--- /dev/null
+++ b/dev-libs/uthash/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>proxy-maintainers</herd>
+ <maintainer>
+ <email>bugs@bergstroem.nu</email>
+ <name>Johan Bergström</name>
+ <description>Maintainer. Assign bugs to him</description>
+ </maintainer>
+ <longdescription lang="en">
+</longdescription>
+ <upstream>
+ <remote-id type="github">troydhanson/uthash</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-libs/uthash/uthash-1.9.7.ebuild b/dev-libs/uthash/uthash-1.9.7.ebuild
new file mode 100644
index 000000000000..ab2f563190cd
--- /dev/null
+++ b/dev-libs/uthash/uthash-1.9.7.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="4"
+
+inherit toolchain-funcs
+
+DESCRIPTION="An easy-to-use hash implementation for C programmers"
+HOMEPAGE="http://uthash.sourceforge.net"
+SRC_URI="mirror://sourceforge/uthash/${P}.tar.bz2"
+
+LICENSE="BSD-1"
+SLOT="0"
+KEYWORDS="amd64 ~arm ppc ~ppc64 sparc x86"
+IUSE="test"
+
+DEPEND="test? ( dev-lang/perl )"
+RDEPEND=""
+
+src_test() {
+ cd tests
+ sed -i "/CFLAGS/s/-O3/${CFLAGS}/" Makefile || die "sed cflags failed"
+ emake CC="$(tc-getCC)"
+}
+
+src_install() {
+ insinto /usr/include
+ doins src/*.h || die "doins failed"
+
+ dodoc doc/txt/{ChangeLog,userguide,ut*}.txt
+}
diff --git a/dev-libs/uthash/uthash-1.9.9.ebuild b/dev-libs/uthash/uthash-1.9.9.ebuild
new file mode 100644
index 000000000000..e1cdddbf2b10
--- /dev/null
+++ b/dev-libs/uthash/uthash-1.9.9.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+inherit toolchain-funcs
+
+DESCRIPTION="An easy-to-use hash implementation for C programmers"
+HOMEPAGE="http://troydhanson.github.io/uthash/index.html"
+SRC_URI="https://github.com/troydhanson/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD-1"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~sparc ~x86"
+IUSE="test"
+
+DEPEND="sys-apps/sed
+ test? ( dev-lang/perl )"
+RDEPEND=""
+
+src_test() {
+ cd tests || die
+ sed -i "/CFLAGS/s/-O3/${CFLAGS}/" Makefile || die
+ emake CC="$(tc-getCC)"
+}
+
+src_install() {
+ insinto /usr/include
+ doins src/*.h
+
+ dodoc doc/{ChangeLog,todo,userguide,ut*}.txt
+}